forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sci-electronics/xcircuit: Version bump to latest 3.8.x.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
63 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST xcircuit-3.7.48.tgz 1648993 SHA256 4d6e7cb155f41d2643e9d1a07865de49aa31cbd238a951ac5d74e13e4c03457b SHA512 686bd2139a6d2d5011b51ff500ea9ffb4007326734eafc0afeec250cb844d8107a344c4ef90d2ed747d8485e7dc8dca69c7e62fd785fc17d3f3460212a0dcb84 WHIRLPOOL 6f935190c7a95e3d4dac48090efa18418ca9e6e8e345f23a27da35debf0aeae7ca1223e1b2e975cce1619d3f2ff878e72a0cd3bee103624214955397c40739ce | ||
DIST xcircuit-3.8.77.tgz 1523126 SHA256 1d39401a41ffa66098ef482395539cc546b293ef372a1e1a464947c05abfce26 SHA512 a65ac0962aa4828ce75610cd6fe3bb0e934a9c563ac08cccfaf3e8ba1f1c8bf34c5d339bcce18d170a5a2a840ba9a435421c0826dd778b66efa3847685847fda WHIRLPOOL b5c33a5c01c17e3f1585f31d283a08cbc3492a448252f7f8fd10730f7114a8f21be5781340ea4c95ebfeb263eaff117e64528019df69cc3d3c75151005bc84a8 | ||
DIST xcircuit-3.8.81.tgz 1533514 SHA256 919a52b2e2db977d49e75f91ee941dfe85efc9bbf7cb8c9b3cc8c4b3114bf416 SHA512 6e7c5de33e90f9a6b004ea3e78977dec62ce0b319a02f01e19b89539e298de5b30b80aa99ee6ac50d39603b3a359313a514a40de2dc1489f6c3f3b33b235254f WHIRLPOOL d56e1d4e12be943d0b4d2cae539ed3779541b8350d23963d916795d17521f8d2b1e85546e02594c257c6dba2eea9b763858add36c37e6f85fe0efc6b000fd56f | ||
DIST xcircuit-3.8.83.tgz 1533560 SHA256 263d54f455b0624b3497d375ebf1f557c9b99900a64cb21c013db8690d5248df SHA512 2fc798c7fd1e098e4cf1605cd46007ae980be27373cdc0089a129f4a98be475c6a7452e8498c39d28bc97e7b8d7dcd9ef35e029ca416fb49144f00bf83c4b36a WHIRLPOOL a3b56df2e58d3f6107eda1e35417a029df04cbe8611778704dbbfe95abedb32fde16f96bfe1959b73f863f2c04854c3e03b7ad7dfa371237da5eabdf90e7f49b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
AUTOTOOLS_AUTORECONF=yes | ||
|
||
inherit autotools-utils multilib | ||
|
||
DESCRIPTION="Circuit drawing and schematic capture program" | ||
SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz" | ||
HOMEPAGE="http://opencircuitdesign.com/xcircuit" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
app-text/ghostscript-gpl | ||
dev-lang/tk:0 | ||
sys-libs/zlib | ||
x11-libs/libX11 | ||
x11-libs/libXt | ||
x11-libs/libXpm | ||
x11-libs/libSM | ||
x11-libs/libICE" | ||
RDEPEND=${DEPEND} | ||
|
||
RESTRICT="test" #131024 | ||
|
||
AUTOTOOLS_IN_SOURCE_BUILD=1 | ||
|
||
src_prepare() { | ||
# automake-1.12 | ||
sed \ | ||
-e '/AM_C_PROTOTYPES/d' \ | ||
-i configure.in || die | ||
# automake-1.13 | ||
mv configure.{in,ac} || die | ||
autotools-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
export loader_run_path="/usr/$(get_libdir)" | ||
local myeconfargs=( | ||
--disable-dependency-tracking | ||
--with-tcl | ||
--with-ngspice | ||
) | ||
autotools-utils_src_configure | ||
} | ||
|
||
src_compile() { | ||
autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults" | ||
} | ||
|
||
src_install () { | ||
autotools-utils_src_install \ | ||
appdefaultsdir="/usr/share/X11/app-defaults" \ | ||
appmandir="/usr/share/man/man1" | ||
} |