forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-im/telegram-desktop: Bump to 4.12.2
Bug: https://bugs.gentoo.org/917409 Bug: https://bugs.gentoo.org/919201 Thanks-to: Pacho Ramos <[email protected]> Thanks-to: Aleksey <[email protected]> Signed-off-by: Esteve Varela Colominas <[email protected]> Signed-off-by: Yixun Lan <[email protected]>
- Loading branch information
Showing
2 changed files
with
228 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST tdesktop-4.10.3-full.tar.gz 67750018 BLAKE2B 395484594dc201019b5cdf3fdaabe1155dca99504b74e65951b6264b61ed0403bb1e016542c6c59370b3ee39d1449ea223409fc64fd6bff723c1be43b615570a SHA512 1e7c0f32b4e17c1f1c39aa9a4f35ce2867324c4410a30fde2c2d6ca5d5fe59a84f58f93cb6b4f8c7ad04fa0adcaf5a276dd2aa7dee0ef34446e6bb95fafa49d6 | ||
DIST tdesktop-4.11.7-full.tar.gz 68388327 BLAKE2B 3be938534ff599e44b4ded384c47914a0e7992f5a3a6901e04c60e53386cf1994f19f6dec6195bf44bfbc93f965f16b05644a7ef786deacdc10c021a9ada882d SHA512 d8557a8e11a3b2f34fb65c5a3fafaebc31d93b5855f947b1049e5e7c7e5a5e161df708ba1882cc096f9a789fac56d3bbcbe640d2a026cb8355e946b735995501 | ||
DIST tdesktop-4.12.2-full.tar.gz 67796891 BLAKE2B b5d0d4d065bf586ffade6b81abbb7854d06516a3f0f34071d9c91d8fa7b2f40b5f79917a07039ec5d030a0265cf60a8255b9d9a748541d480448dd1224d1b86a SHA512 af890d693ec24ff96b48a1c3eab29e199c2a324db35ead33afc733ac8dedefa67574d3540dd87f0e19eb91435c699d839ced579b1485028fab737c1c02eaeff6 | ||
DIST tdesktop-4.8.1-full.tar.gz 63997319 BLAKE2B daac461f0b3205bf647027329660b43f4646db987e27bfe2a2848bfbfb3309c503132d1533f26e95512520417d30f5063b1c395b174787aa7533727549ee77e5 SHA512 4dc495e4502bdba634c4468af4f1321aef1152d619c811f004489f8616504a465069508239eae41a08a83e190a61d26881733ebc38dd88160f81dce070bb0567 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,227 @@ | ||
# Copyright 2020-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{10..12} ) | ||
|
||
inherit xdg cmake python-any-r1 optfeature flag-o-matic | ||
|
||
DESCRIPTION="Official desktop client for Telegram" | ||
HOMEPAGE="https://desktop.telegram.org" | ||
|
||
MY_P="tdesktop-${PV}-full" | ||
SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz" | ||
S="${WORKDIR}/${MY_P}" | ||
|
||
LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~riscv" | ||
IUSE="dbus enchant +fonts screencast qt6 qt6-imageformats wayland webkit +X" | ||
REQUIRED_USE=" | ||
qt6-imageformats? ( qt6 ) | ||
" | ||
|
||
KIMAGEFORMATS_RDEPEND=" | ||
media-libs/libavif:= | ||
media-libs/libheif:= | ||
>=media-libs/libjxl-0.8.0 | ||
" | ||
CDEPEND=" | ||
!net-im/telegram-desktop-bin | ||
app-arch/lz4:= | ||
dev-cpp/abseil-cpp:= | ||
>=dev-cpp/glibmm-2.77:2.68 | ||
dev-libs/glib:2 | ||
dev-libs/libdispatch | ||
dev-libs/openssl:= | ||
dev-libs/protobuf | ||
dev-libs/xxhash | ||
media-libs/libjpeg-turbo:= | ||
~media-libs/libtgvoip-2.4.4_p20221208 | ||
media-libs/openal | ||
media-libs/opus | ||
media-libs/rnnoise | ||
~media-libs/tg_owt-0_pre20230921:=[screencast=,X=] | ||
media-video/ffmpeg:=[opus,vpx] | ||
sys-libs/zlib:=[minizip] | ||
virtual/opengl | ||
!enchant? ( >=app-text/hunspell-1.7:= ) | ||
enchant? ( app-text/enchant:= ) | ||
!qt6? ( | ||
>=dev-qt/qtcore-5.15:5= | ||
>=dev-qt/qtgui-5.15:5=[dbus?,jpeg,png,wayland?,X?] | ||
>=dev-qt/qtimageformats-5.15:5 | ||
>=dev-qt/qtnetwork-5.15:5[ssl] | ||
>=dev-qt/qtsvg-5.15:5 | ||
>=dev-qt/qtwidgets-5.15:5[png,X?] | ||
kde-frameworks/kcoreaddons:5 | ||
webkit? ( | ||
>=dev-qt/qtdeclarative-5.15:5 | ||
>=dev-qt/qtwayland-5.15:5 | ||
) | ||
) | ||
qt6? ( | ||
>=dev-qt/qtbase-6.5:6=[dbus?,gui,network,opengl,wayland?,widgets,X?] | ||
>=dev-qt/qtimageformats-6.5:6 | ||
>=dev-qt/qtsvg-6.5:6 | ||
webkit? ( | ||
>=dev-qt/qtdeclarative-6.5:6 | ||
>=dev-qt/qtwayland-6.5:6[compositor] | ||
) | ||
qt6-imageformats? ( | ||
>=dev-qt/qtimageformats-6.5:6= | ||
${KIMAGEFORMATS_RDEPEND} | ||
) | ||
) | ||
X? ( | ||
x11-libs/libxcb:= | ||
x11-libs/xcb-util-keysyms | ||
) | ||
" | ||
RDEPEND="${CDEPEND} | ||
webkit? ( net-libs/webkit-gtk:4.1 net-libs/webkit-gtk:6 ) | ||
" | ||
DEPEND="${CDEPEND} | ||
>=dev-cpp/cppgir-0_p20230926 | ||
>=dev-cpp/ms-gsl-4 | ||
dev-cpp/range-v3 | ||
" | ||
BDEPEND=" | ||
${PYTHON_DEPS} | ||
>=dev-cpp/cppgir-0_p20230926 | ||
>=dev-util/cmake-3.16 | ||
dev-util/gdbus-codegen | ||
virtual/pkgconfig | ||
wayland? ( dev-util/wayland-scanner ) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/tdesktop-4.10.0-system-cppgir.patch" | ||
"${FILESDIR}/tdesktop-4.10.5-qt_compare.patch" | ||
) | ||
|
||
pkg_pretend() { | ||
if has ccache ${FEATURES}; then | ||
ewarn "ccache does not work with ${PN} out of the box" | ||
ewarn "due to usage of precompiled headers" | ||
ewarn "check bug https://bugs.gentoo.org/715114 for more info" | ||
ewarn | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
# Bundle kde-frameworks/kimageformats for qt6, since it's impossible to | ||
# build in gentoo right now. | ||
if use qt6-imageformats; then | ||
sed -e 's/DESKTOP_APP_USE_PACKAGED_LAZY/TRUE/' -i \ | ||
cmake/external/kimageformats/CMakeLists.txt || die | ||
printf '%s\n' \ | ||
'Q_IMPORT_PLUGIN(QAVIFPlugin)' \ | ||
'Q_IMPORT_PLUGIN(HEIFPlugin)' \ | ||
'Q_IMPORT_PLUGIN(QJpegXLPlugin)' \ | ||
>> cmake/external/qt/qt_static_plugins/qt_static_plugins.cpp || die | ||
fi | ||
# kde-frameworks/kcoreaddons is bundled when using qt6. | ||
|
||
# Happily fail if libraries aren't found... | ||
find -type f \( -name 'CMakeLists.txt' -o -name '*.cmake' \) \ | ||
\! -path './Telegram/lib_webview/CMakeLists.txt' \ | ||
\! -path './cmake/external/expected/CMakeLists.txt' \ | ||
\! -path './cmake/external/kcoreaddons/CMakeLists.txt' \ | ||
\! -path './cmake/external/qt/package.cmake' \ | ||
-print0 | xargs -0 sed -i \ | ||
-e '/pkg_check_modules(/s/[^ ]*)/REQUIRED &/' \ | ||
-e '/find_package(/s/)/ REQUIRED)/' || die | ||
# Make sure to check the excluded files for new | ||
# CMAKE_DISABLE_FIND_PACKAGE entries. | ||
|
||
# Control QtDBus dependency from here, to avoid messing with QtGui. | ||
if ! use dbus; then | ||
sed -e '/find_package(Qt[^ ]* OPTIONAL_COMPONENTS/s/DBus *//' \ | ||
-i cmake/external/qt/package.cmake || die | ||
fi | ||
|
||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# Evil flag (bug #919201) | ||
filter-flags -fno-delete-null-pointer-checks | ||
|
||
# The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep | ||
# the same state across both projects. | ||
# See https://bugs.gentoo.org/866055 | ||
append-cppflags '-DNDEBUG' | ||
|
||
local qt=$(usex qt6 6 5) | ||
local mycmakeargs=( | ||
-DQT_VERSION_MAJOR=${qt} | ||
|
||
# Control automagic dependencies on certain packages | ||
## Header-only lib, some git version. | ||
-DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}Quick=$(usex !webkit) | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}QuickWidgets=$(usex !webkit) | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}WaylandClient=$(usex !wayland) | ||
## Only used in Telegram/lib_webview/CMakeLists.txt | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}WaylandCompositor=$(usex !webkit) | ||
## KF6CoreAddons is currently unavailable in ::gentoo | ||
-DCMAKE_DISABLE_FIND_PACKAGE_KF${qt}CoreAddons=$(usex qt6) | ||
|
||
-DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X) | ||
-DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland) | ||
## Enables enchant and disables hunspell | ||
-DDESKTOP_APP_USE_ENCHANT=$(usex enchant) | ||
## Use system fonts instead of bundled ones | ||
-DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts) | ||
) | ||
|
||
if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then | ||
einfo "Found custom API credentials" | ||
mycmakeargs+=( | ||
-DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}" | ||
-DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}" | ||
) | ||
else | ||
# https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml | ||
# Building with snapcraft API credentials by default | ||
# Custom API credentials can be obtained here: | ||
# https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md | ||
# After getting credentials you can export variables: | ||
# export MY_TDESKTOP_API_ID="17349"" | ||
# export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb" | ||
# and restart the build" | ||
# you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop | ||
# portage will use custom variable every build automatically | ||
mycmakeargs+=( | ||
-DTDESKTOP_API_ID="611335" | ||
-DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c" | ||
) | ||
fi | ||
|
||
cmake_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
if ! use X && ! use screencast; then | ||
ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!" | ||
ewarn | ||
fi | ||
if use wayland && ! use qt6; then | ||
ewarn "Wayland-specific integrations have been deprecated with Qt5." | ||
ewarn "The app will continue to function under wayland, but some" | ||
ewarn "functionality may be reduced." | ||
ewarn "These integrations are only supported when built with Qt6." | ||
ewarn | ||
fi | ||
if use qt6 && ! use qt6-imageformats; then | ||
elog "Enable USE=qt6-imageformats for AVIF, HEIF and JpegXL support" | ||
elog | ||
fi | ||
optfeature_header | ||
if ! use qt6; then | ||
optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats[avif,heif,jpegxl] | ||
fi | ||
} |