Skip to content

Commit

Permalink
media-libs/qt-gstreamer: Drop USE=qt4,qt5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
a17r committed Aug 31, 2017
1 parent 9475b3b commit e7b7fc4
Showing 1 changed file with 54 additions and 0 deletions.
54 changes: 54 additions & 0 deletions media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

if [[ ${PV} != *9999* ]]; then
SRC_URI="https://gstreamer.freedesktop.org/src/qt-gstreamer/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
else
EGIT_REPO_URI="https://anongit.freedesktop.org/git/gstreamer/qt-gstreamer.git"
inherit git-r3
fi

inherit cmake-utils

DESCRIPTION="C++ bindings for GStreamer with a Qt-style API"
HOMEPAGE="https://gstreamer.freedesktop.org/modules/qt-gstreamer.html"

LICENSE="LGPL-2.1"
SLOT="0"
IUSE="test"

RDEPEND="
dev-libs/glib:2
dev-libs/boost:=
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
"
DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
"

PATCHES=(
"${FILESDIR}/${P}-gstreamer15.patch"
"${FILESDIR}/${P}-boost157.patch"
)

# bug 497880
RESTRICT="test"

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5Declarative=ON
-DQTGSTREAMER_EXAMPLES=OFF
-DQTGSTREAMER_TESTS=$(usex test)
-DQT_VERSION=5
)
cmake-utils_src_configure
}

0 comments on commit e7b7fc4

Please sign in to comment.