Skip to content

Commit

Permalink
dev-util/aruba: add ruby23 revision
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Sep 1, 2016
1 parent 092dbb6 commit e7df364
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions dev-util/aruba/aruba-0.6.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_RECIPE_TEST="cucumber"
RUBY_FAKEGEM_EXTRADOC="History.md README.md"

RUBY_FAKEGEM_GEMSPEC="aruba.gemspec"

inherit ruby-fakegem

DESCRIPTION="Cucumber steps for driving out command line applications"
HOMEPAGE="https://github.com/cucumber/aruba"
LICENSE="MIT"

KEYWORDS="~amd64"
SLOT="0"
IUSE=""

DEPEND="${DEPEND} test? ( sys-devel/bc )"
RDEPEND="${RDEPEND}"

ruby_add_rdepend "
>=dev-ruby/childprocess-0.3.6
>=dev-ruby/rspec-expectations-2.7:2
>=dev-util/cucumber-1.1.1"

ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.11:2 >=dev-ruby/bcat-0.6.1 )"

all_ruby_prepare() {
# Remove bundler-related code.
sed -i -e '/[Bb]undler/d' Rakefile || die
rm Gemfile || die

# Remove references to git ls-files.
sed -i -e '/git ls-files/d' aruba.gemspec || die
}

0 comments on commit e7df364

Please sign in to comment.