Skip to content

Commit

Permalink
dev-util/debhelper: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
Jeroen Roovers committed Aug 29, 2016
1 parent d42fc0f commit e7fec09
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/debhelper/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST debhelper_9.20150101.tar.gz 545089 SHA256 fd8d81d71d1bb0ba4b58c517465551231dd60811b98c867e4344bc55ec6a45f2 SHA512 62c85f751627cf0bdac392c6e8c5298995030962b7753047414e740b3767d722c209329c9f0c3c07c94e82bbb7250c163ce49b681e268a0decdbd19b72ea132a WHIRLPOOL 31315544c3ee695a53ef2310ad69e59c68fb0b73399305b9fe57ceb7b01faab72995e01aed270300dd0fbaed2686a5b565a8a08cfc31c720c5baa2a6c475ac4e
DIST debhelper_9.20160403.tar.xz 336472 SHA256 947cdf0a8b51e5f89986f5995a14756c11597b821d7deca23e5c951131866940 SHA512 d159fd61ae40a9b2476f3b868f325acbcaa158143c436d878c67b71445a599df26252689cfee551672b3624b64fde1d61879b57cb2d4252b4513f7e0d4fa2d08 WHIRLPOOL c2e1783dc02029936b83fb7796645797a3819db4daea2f97a2f9f9855bb630e75aa44c9119cd859905a30d77e2180fdbbcabe4319f6d503466d75694c28915f0
DIST debhelper_9.20160709.tar.xz 343084 SHA256 c53f6c833a8edd427e98307690c00dcd252360ea2a649196facf16a39e4dd4e2 SHA512 69ecaa2e964d0c5596182a50b119955fdb2193f88ad6d55d55efa2fbfe8a1d7ef5722756dc7fd16484494fa109fd21d17a78468401fbcd581117fb3ecc138bde WHIRLPOOL 719baab9551b6d890a01b7ebe5698404e22b6cd0cb636937a344b5154584929762f17c17269ab1544eab18f7e2bf2e7ca91e8b0f9979adb02355de07659990a0
DIST debhelper_9.20160814.tar.xz 344328 SHA256 2834a7c1dbeafd9402ea68948c815dab19d903503c45fd70e676269fccd359c0 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 WHIRLPOOL 334f0aa8075896ec13a061b9841adb5f2b7c5fa6996b507785f50389c86c48e3c89a84ff1049ae7d7cbe4876b649010f892f54f1074ecafd76061bf0588e65d6
70 changes: 70 additions & 0 deletions dev-util/debhelper/debhelper-9.20160814.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils toolchain-funcs

DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
IUSE="test"
DH_LINGUAS=( de es fr )
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"

NLS_DEPEND=$(
printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
)

RDEPEND="
>=dev-lang/perl-5.10:=
>=app-arch/dpkg-1.17
dev-perl/TimeDate
virtual/perl-Getopt-Long
"
DEPEND="${RDEPEND}
${NLS_DEPEND}
test? ( dev-perl/Test-Pod )
"

S=${WORKDIR}/${PN}

src_compile() {
tc-export CC

local LANGS="" USE_NLS=no lingua
for lingua in ${DH_LINGUAS[@]}; do
if use linguas_${lingua}; then
LANGS+=" ${lingua}"
USE_NLS=yes
fi
done

emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
}

src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
dodoc doc/* debian/changelog
docinto examples
dodoc examples/*
local lingua
for manfile in *.1 *.7 ; do
for lingua in ${DH_LINGUAS[@]}; do
case ${manfile} in
*.${lingua}.?)
use linguas_${lingua} \
&& cp ${manfile} "${T}"/${manfile/.${lingua}/} \
&& doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
;;
*)
doman ${manfile}
;;
esac
done
done
}

0 comments on commit e7fec09

Please sign in to comment.