Skip to content

Commit

Permalink
app-benchmarks/pipebench: EAPI bump, bug 605728
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
akhuettel committed Apr 8, 2017
1 parent b9e23fe commit e810c4d
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Measures the speed of stdin/stdout communication"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~arm-linux ~x86-linux"
IUSE=""

src_prepare() {
sed -i Makefile \
-e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
-e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
-e "s:/usr/local/bin/:${ED}/usr/bin:" \
-e "s:/usr/local/man/man1/:${ED}/usr/share/man/man1:" \
|| die "sed Makefile"
default
}

src_compile() {
emake CC=$(tc-getCC)
}

src_install() {
dodir /usr/{bin,share/man/man1}
emake install
dodoc README
}

0 comments on commit e810c4d

Please sign in to comment.