Skip to content

Commit

Permalink
dev-ros/qt_gui_cpp: upstream sip patch
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jul 15, 2020
1 parent a8be76b commit e83f50f
Show file tree
Hide file tree
Showing 2 changed files with 26 additions and 0 deletions.
25 changes: 25 additions & 0 deletions dev-ros/qt_gui_cpp/files/sip.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 5ecb3a219146816916c4a94e32664850548a2085 Mon Sep 17 00:00:00 2001
From: Johannes Meyer <[email protected]>
Date: Tue, 7 Jul 2020 01:20:51 +0200
Subject: [PATCH] qt_gui_cpp_sip: declare private assignment operator for SIP
(#226)

---
qt_gui_cpp/src/qt_gui_cpp_sip/plugin_context.sip | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/qt_gui_cpp/src/qt_gui_cpp_sip/plugin_context.sip b/qt_gui_cpp/src/qt_gui_cpp_sip/plugin_context.sip
index 286d52e6..1d37a37d 100644
--- a/src/qt_gui_cpp_sip/plugin_context.sip
+++ b/src/qt_gui_cpp_sip/plugin_context.sip
@@ -25,6 +25,10 @@ public:

void reloadPlugin();

+private:
+
+ PluginContext& operator=(const PluginContext&);
+
};

};
1 change: 1 addition & 0 deletions dev-ros/qt_gui_cpp/qt_gui_cpp-0.4.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,4 +30,5 @@ DEPEND="${RDEPEND}
"
PATCHES=(
"${FILESDIR}/libdir.patch"
"${FILESDIR}/sip.patch"
)

0 comments on commit e83f50f

Please sign in to comment.