Skip to content

Commit

Permalink
app-misc/fdupes: Synced live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 13, 2021
1 parent b8ed036 commit e88d555
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 32 deletions.
43 changes: 25 additions & 18 deletions app-misc/fdupes/fdupes-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,34 +1,41 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit flag-o-matic git-r3 toolchain-funcs

MY_P="${PN}-${PV/_pre/-PR}"
inherit toolchain-funcs

DESCRIPTION="Identify/delete duplicate files residing within specified directories"
HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"

if [[ "${PV}" == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
else
SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
LICENSE="MIT"
SLOT="0"
IUSE="+ncurses"

KEYWORDS=""
SRC_URI=""

S="${WORKDIR}/${MY_P}"

PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
RDEPEND="
dev-libs/libpcre2[pcre32]
ncurses? ( sys-libs/ncurses:0= )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

DOCS=( CHANGES CONTRIBUTORS README )

src_prepare() {
default
[[ "${PV}" == *9999 ]] && eautoreconf
}

src_configure() {
append-lfs-flags
tc-export CC
econf $(use_with ncurses)
}

src_install() {
emake PREFIX="/usr" DESTDIR="${D}" install
einstalldocs
src_compile() {
emake CC=$(tc-getCC)
}
14 changes: 0 additions & 14 deletions app-misc/fdupes/files/fdupes-9999-gentoo.patch

This file was deleted.

0 comments on commit e88d555

Please sign in to comment.