Skip to content

Commit

Permalink
media-gfx/apngasm: bump to 3.1.10
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/824830
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Stephan Hartmann <[email protected]>
  • Loading branch information
stha09 committed Dec 22, 2021
1 parent fa5bd0d commit e8a0601
Show file tree
Hide file tree
Showing 3 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/apngasm/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST apngasm-2.91-src.zip 597267 BLAKE2B a34a765fef49aa0ac29973b8dc450bfcdfe7aa83dffe19919f916a136db3d0bfebf3c1fac79bfb81a3900cee87afd888469e5432500d181a9539696b4573a42b SHA512 2415389a989f7a7ff7f3e1328f7920c7515c9a492c89ef216ff53db68fe2f1a674ff60d5f4bfd5a8c710f625456557ae7d5b25f486ac826e3113976cd9fc11dc
DIST apngasm-3.1.10.tar.gz 620031 BLAKE2B 6885b87815e76e8b9eed58548568bf821dfdf61579f83fc1aa977638f34c2112ebbfebba3454b0a2cfc01b465e570a7976e0fb8046a0762e9d35cf30e3d3f4cd SHA512 670d75251ddc771f9b2b4a1f401066f2012a6814bec781b918f1d9e8960835654c66c3d19b4c8920d5186d85af12cdc4bba8b61c8f3d349b4fc70513d8ecb34e
40 changes: 40 additions & 0 deletions media-gfx/apngasm/apngasm-3.1.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="create an APNG from multiple PNG files"
HOMEPAGE="https://github.com/apngasm/apngasm"
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-libs/boost:=
media-libs/libpng:0=
sys-libs/zlib:=
"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-3.1.10-static.patch"
)

src_prepare() {
sed -i -e 's|man/man1|share/man/man1|g' cli/CMakeLists.txt || die

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DLIB_INSTALL_DIR=$(get_libdir)
-DJAVA=OFF
-DRUBY=OFF
)
cmake_src_configure
}
55 changes: 55 additions & 0 deletions media-gfx/apngasm/files/apngasm-3.1.10-static.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -55,18 +55,6 @@ set_target_properties(${APNGASM_DYNAMIC_LIB_TARGET}
CXX_STANDARD 20
)

-# Add the static library/archive
-set(APNGASM_STATIC_LIB_TARGET apngasm-static)
-add_library(${APNGASM_STATIC_LIB_TARGET}
- ${APNGASM_SOURCES}
-)
-set_target_properties(${APNGASM_STATIC_LIB_TARGET}
- PROPERTIES
- POSITION_INDEPENDENT_CODE TRUE
- OUTPUT_NAME apngasm
- CXX_STANDARD 20
-)
-
# Add libraries/includes
#target_link_libraries(${APNGASM_DYNAMIC_LIB_TARGET} stdc++fs)
#target_link_libraries(${APNGASM_STATIC_LIB_TARGET} stdc++fs)
@@ -74,11 +62,9 @@ set_target_properties(${APNGASM_STATIC_LIB_TARGET}
find_package(PNG REQUIRED)
include_directories(${PNG_INCLUDE_DIR})
target_link_libraries(${APNGASM_DYNAMIC_LIB_TARGET} ${PNG_LIBRARY})
-target_link_libraries(${APNGASM_STATIC_LIB_TARGET} ${PNG_LIBRARY})
message(${PNG_VERSION_STRING})

target_link_libraries(${APNGASM_DYNAMIC_LIB_TARGET} ${ZLIB_LIBRARIES})
-target_link_libraries(${APNGASM_STATIC_LIB_TARGET} ${ZLIB_LIBRARIES})

#if (APPLE OR WIN32)
# set(Boost_USE_STATIC_LIBS ON)
@@ -88,13 +74,10 @@ target_link_libraries(${APNGASM_STATIC_LIB_TARGET} ${ZLIB_LIBRARIES})
find_package(Boost REQUIRED COMPONENTS program_options regex system)
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
target_link_libraries(${APNGASM_DYNAMIC_LIB_TARGET} Boost::program_options Boost::regex Boost::system)
-target_link_libraries(${APNGASM_STATIC_LIB_TARGET} Boost::program_options Boost::regex Boost::system)

get_target_property(APNGASM_DYNAMIC_LIB_TARGET_NAME ${APNGASM_DYNAMIC_LIB_TARGET} OUTPUT_NAME)
-get_target_property(APNGASM_STATIC_LIB_TARGET_NAME ${APNGASM_STATIC_LIB_TARGET} OUTPUT_NAME)
set(APNGASM_LIBRARIES
${PROJECT_BINARY_DIR}/${CMAKE_SHARED_LIBRARY_PREFIX}${APNGASM_DYNAMIC_LIB_TARGET_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX}
- ${PROJECT_BINARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}${APNGASM_STATIC_LIB_TARGET_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX}
)

# Installation
@@ -107,7 +90,6 @@ endif ()
install(
TARGETS
${APNGASM_DYNAMIC_LIB_TARGET}
- ${APNGASM_STATIC_LIB_TARGET}
DESTINATION ${LIB_INSTALL_DIR}
)

0 comments on commit e8a0601

Please sign in to comment.