Skip to content

Commit

Permalink
dev-libs/urdfdom: bump to 0.4.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Feb 9, 2016
1 parent 8f31aa8 commit e8c2019
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/urdfdom/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST urdfdom-0.3.0.tar.gz 58477 SHA256 2e3f14bdb47e237f2ba75fc9e26008a133210c15b52f73c9112adeb0b0d1da6c SHA512 ce49dca7963d7301cd1aae58fff9fb4341144ecba9b7ce2efa74ee98424bd7fde6e891331944b7cd008bb974cb19df3eee0f88a77dad09fb72feb63b45bbc6d3 WHIRLPOOL 5c847cbb0bf28ed39f8fa0cfbe27246d863085b761a032764e570dac012ebc27ee2d175a1e599e5fc7495d14768b42a3dd82aeab7f513b1ff62d23e5f50509ef
DIST urdfdom-0.4.1.tar.gz 62609 SHA256 6552e2b6de63b0ff7300909fa69d9bab18381b6184a05dc2fe744b2334a9fde5 SHA512 4718f93b6a17d52c377757deda34cdac2cd462fc820e188c1d649e7397a17f1df424e2ef40134f3f313066d7b005681e44f6ec7142c7c56f08660d622209e255 WHIRLPOOL b3d498ae7b24e9411d287163f7d08d8c94785682ee317844130d0624a673d887b00a9b467e68a464b60d3c161ea8434ad7e729ac676de7b3cb28a8f34fa47555
69 changes: 69 additions & 0 deletions dev-libs/urdfdom/urdfdom-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros/urdfdom"
fi

PYTHON_COMPAT=( python2_7 )

inherit ${SCM} distutils-r1 cmake-utils

if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
SRC_URI=""
else
KEYWORDS="~amd64 ~arm"
SRC_URI="https://github.com/ros/urdfdom/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi

DESCRIPTION="URDF (U-Robot Description Format) library"
HOMEPAGE="http://ros.org/wiki/urdf"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="dev-libs/urdfdom_headers
dev-libs/console_bridge
dev-libs/tinyxml
dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"

PY_S="${S}/urdf_parser_py"

src_prepare() {
sed -i -e 's/set(CMAKE_INSTALL_LIBDIR/#/' CMakeLists.txt || die
cmake-utils_src_prepare
cd "${PY_S}"
S="${PY_S}" distutils-r1_src_prepare
}

src_configure() {
local mycmakeargs=( "-DPYTHON=FALSE" )
cmake-utils_src_configure
cd "${PY_S}"
S="${PY_S}" distutils-r1_src_configure
}

src_compile() {
cmake-utils_src_compile
cd "${PY_S}"
S="${PY_S}" distutils-r1_src_compile
}

src_test() {
cmake-utils_src_test
cd "${PY_S}"
S="${PY_S}" distutils-r1_src_test
}

src_install() {
cmake-utils_src_install
cd "${PY_S}"
S="${PY_S}" distutils-r1_src_install
}

0 comments on commit e8c2019

Please sign in to comment.