Skip to content

Commit

Permalink
www-servers/thttpd: migrate to GLEP 81
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/781548
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Jul 20, 2021
1 parent e231c7d commit e8f023d
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 26 deletions.
67 changes: 67 additions & 0 deletions www-servers/thttpd/thttpd-2.27.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic toolchain-funcs

if [[ ${PV} = 9999* ]]
then
EGIT_REPO_URI="https://github.com/blueness/sthttpd.git"
inherit git-r3
else
MY_P="s${P}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/blueness/sthttpd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
fi

DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver"
HOMEPAGE="https://github.com/blueness/sthttpd http://opensource.dyc.edu/sthttpd"

LICENSE="BSD GPL-2"
SLOT="0"

RDEPEND="
acct-group/thttpd
acct-user/thttpd
virtual/libcrypt:=
"
DEPEND="${RDEPEND}"

WEBROOT="/var/www/localhost"

src_prepare() {
eapply "${FILESDIR}"/thttpd-renamed-htpasswd.patch
mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
eapply_user
eautoreconf -f -i
}

src_configure() {
econf WEBDIR="${EPREFIX}/${WEBROOT}/htdocs"
}

src_install() {
default

newinitd "${FILESDIR}"/thttpd.init.1 thttpd
newconfd "${FILESDIR}"/thttpd.confd.1 thttpd

insinto /etc/logrotate.d
newins "${FILESDIR}/thttpd.logrotate" thttpd

insinto /etc/thttpd
doins "${FILESDIR}"/thttpd.conf.sample

# move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
mv "${ED}"/${WEBROOT}/htdocs "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
mkdir "${ED}"/${WEBROOT}/htdocs || die

keepdir ${WEBROOT}/htdocs

chown root:thttpd "${ED}/usr/sbin/makeweb" || die
chmod 2751 "${ED}/usr/sbin/makeweb" || die
chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" || die
}
40 changes: 14 additions & 26 deletions www-servers/thttpd/thttpd-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI=7

inherit autotools flag-o-matic toolchain-funcs user
inherit autotools flag-o-matic toolchain-funcs

if [[ ${PV} = 9999* ]]
then
Expand All @@ -22,23 +22,15 @@ HOMEPAGE="https://github.com/blueness/sthttpd http://opensource.dyc.edu/sthttpd"
LICENSE="BSD GPL-2"
SLOT="0"

RDEPEND="virtual/libcrypt:="
RDEPEND="
acct-group/thttpd
acct-user/thttpd
virtual/libcrypt:=
"
DEPEND="${RDEPEND}"

WEBROOT="/var/www/localhost"

THTTPD_USER=thttpd
THTTPD_GROUP=thttpd
THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"

DOCS=( TODO )

pkg_setup() {
ebegin "Creating thttpd user and group"
enewgroup ${THTTPD_GROUP}
enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
}

src_prepare() {
eapply "${FILESDIR}"/thttpd-renamed-htpasswd.patch
mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
Expand All @@ -47,7 +39,7 @@ src_prepare() {
}

src_configure() {
econf WEBDIR=${THTTPD_DOCROOT}
econf WEBDIR="${EPREFIX}/${WEBROOT}/htdocs"
}

src_install() {
Expand All @@ -62,18 +54,14 @@ src_install() {
insinto /etc/thttpd
doins "${FILESDIR}"/thttpd.conf.sample

#move htdocs to docdir, bug #429632
# move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
mv "${ED}"${WEBROOT}/htdocs \
"${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
mkdir "${ED}"${WEBROOT}/htdocs || die
mv "${ED}"/${WEBROOT}/htdocs "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
mkdir "${ED}"/${WEBROOT}/htdocs || die

keepdir ${WEBROOT}/htdocs

chown root:${THTTPD_GROUP} "${ED}/usr/sbin/makeweb" \
|| die "Failed chown makeweb"
chmod 2751 "${ED}/usr/sbin/makeweb" \
|| die "Failed chmod makeweb"
chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" \
|| die "Failed chmod printenv"
chown root:thttpd "${ED}/usr/sbin/makeweb" || die
chmod 2751 "${ED}/usr/sbin/makeweb" || die
chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" || die
}

0 comments on commit e8f023d

Please sign in to comment.