Skip to content

Commit

Permalink
dev-db/etcd: version bump to 3.0.17
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
zmedico committed Jan 31, 2017
1 parent d1f12cb commit e906718
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/etcd/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST etcd-2.3.7.tar.gz 2209051 SHA256 aa3a6340bb08d072d1d2ecfbe3c1e02235251760d031a2b699ee1710510ee883 SHA512 a551287ebf6e881e2c6a56a7e75c273d125ed2b4b3ea58533e4481bc12ca21167de02820aaa1f4775b81385e96e65f882e97121920be02d72abe82f43652daf9 WHIRLPOOL e01bf51978b9287e9e662f8689630d80eb79aace43fe0c81f1898718ccec1a0a93e53543c3df001dfc12dac2a3844f5a4fe2de28d97654b671648ad93681185a
DIST etcd-3.0.12.tar.gz 2214038 SHA256 d8de5045056814bee623b219102eca17ab573da977562164b261a7e1198fa31b SHA512 ff64cd55fe6fde486600a2438a2c0e4b5161d52e52936d762e3b69006e607809343a7c3f4dd3e28143a93b3fc8a1a9ad9610cbff5659e3d70e2766192e28c5a9 WHIRLPOOL d9d76cfadb20b7c2db75290d46fc938888a7b8830e0d8f12b2fe0404c0c50b78c3bfe6c993edc28702c2eb3526281eb647680de149b2357b06dbbc50d4c44ec7
DIST etcd-3.0.15.tar.gz 2216552 SHA256 c21871f7e1454b1698ff29601a296f4b09365fac25bea45c0af21542d486c307 SHA512 a60f0d36332903133ac4bac0161f5caed8f13afd992e26a8ff98728f6659cf8dcddc4bd77f9df95b695b57f484e993c0da9efe7e4ec420d6c6059334e8829bb6 WHIRLPOOL ab148e2f7218a35ece6305cd173cc201a488663a4419b51fc732f6d562f2a7bc745eedc18475f2497a2ebfdff3523e6199f628dab6679a11bc86110be41e3aaf
DIST etcd-3.0.17.tar.gz 2208002 SHA256 c56c68a8cd5d120a51432f3a79a2c19082a6824493e4bb08c4e440aefbf73d8f SHA512 6eb6a61210f225b6fe7e911ad135e5014f80f71a04adccc3f382ca7b5e1b1b692b12dde26335ecac176cb8b8f4586732cb6e650b32730ec68ef7fbcbba7ab160 WHIRLPOOL 102dc47d120a1f4173b67168e5e51f64025da280ca41161131a6bd2ef9521605ef19e03166848f6c32862a3adbfc0a026f547dc7764018e85f6ac28f89c8d256
DIST etcd-3.1.0.tar.gz 2516872 SHA256 62ecb70a470b45436814e2882d36742a4035e1d62e6634450e71ca0ed951919b SHA512 b377ac492dd842a0f24d2816cd37bb40e692289efbbab63ab54e1b31e7999f26c6c0f2887249f5fd775266919a614699e561ecfc82c8a687d2cf1b25fdb7478f WHIRLPOOL b47a81ea597617a4eab6ee29d51b964f942b8dc324063e6633e2818320ce3b19e1907975a28ca3186cc112553b4e8580c210ad4854945484dcc26f359d0c60e6
61 changes: 61 additions & 0 deletions dev-db/etcd/etcd-3.0.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit user systemd golang-vcs-snapshot

KEYWORDS="~amd64"
EGO_PN=github.com/coreos/etcd
DESCRIPTION="A highly-available key value store for shared configuration and service discovery"
HOMEPAGE="https://${EGO_PN}/"
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc"
DEPEND=">=dev-lang/go-1.6:="
RDEPEND="!dev-db/etcdctl"

src_prepare() {
eapply_user
sed -e 's|GIT_SHA=.*|GIT_SHA=v${PV}|'\
-i "${S}"/src/${EGO_PN}/build || die
}

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
}

src_compile() {
export GOPATH=${S}
cd "${S}"/src/${EGO_PN} || die
./build || die
}

src_install() {
cd "${S}"/src/${EGO_PN} || die
insinto /etc/${PN}
doins "${FILESDIR}/${PN}.conf"
dobin bin/*
dodoc README.md
use doc && dodoc -r Documentation
systemd_dounit "${FILESDIR}/${PN}.service"
systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
dodir /var/lib/${PN}
fowners ${PN}:${PN} /var/lib/${PN}
fperms 755 /var/lib/${PN}
dodir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
fperms 755 /var/log/${PN}
}

src_test() {
cd "${S}"/src/${EGO_PN} || die
./test || die
}

0 comments on commit e906718

Please sign in to comment.