forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-print/cnijfilter2: Bump to 5.40. Bug #645854
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
3 changed files
with
75 additions
and
10 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST cnijfilter2-source-5.20-1.tar.gz 466507 BLAKE2B 1ca96153350a157f56dfed691a04dcbe1e3ab5462b59c0cd919316a7c54a36bbeb34cf4205132f0aa3e5a23f89eb260c35c1a3ee14ea85bc36b9e3b67cd7e3f7 SHA512 60be49d34adf9a4d2cd8337cccb36eb8c078e9712bf8043c3552f1d83c3da307badfe34fc3683c99e3234da30f4ba82e0c4a0b48ea5f78f0d66db1408bd7d495 | ||
DIST cnijfilter2-source-5.40-1.tar.gz 817298 BLAKE2B 1088eb19c70ed9133c38b8a6da9fbc26c42d6f077fda01678fb4485c2db21a17567fab8ab5c9565ece7ea13e5fac3f7c5842e984116d6c595e7a1f19092d3461 SHA512 bb4ce18864037fae9735fcb1b2c3198fe39f8abe0caa754e457e3cb0d03767742d82ff4fddf81451215395b23eea8207a880e238558e0ea2ac5c359186ecd859 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools | ||
|
||
MY_P="${PN}-source-${PV}-1" | ||
|
||
DESCRIPTION="IJ Printer Driver" | ||
HOMEPAGE="https://www.canon.it/" | ||
SRC_URI="http://gdlp01.c-wss.com/gds/3/0100008393/01/${MY_P}.tar.gz" | ||
|
||
LICENSE="Canon-IJ" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND="virtual/libusb:1 | ||
dev-libs/libxml2 | ||
net-print/cups" | ||
RDEPEND="${DEPEND}" | ||
|
||
S="${WORKDIR}"/${MY_P} | ||
|
||
PATCHES=( "${FILESDIR}"/${PN}-5.20-gentoo.patch ) | ||
|
||
src_prepare() { | ||
default | ||
DIRS="cmdtocanonij2 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg" | ||
LIBDIR=com/libs_bin$(usex amd64 64 32) | ||
for d in ${DIRS}; do | ||
mv "${d}"/configure.{in,ac} || die | ||
done | ||
echo "AC_INIT([${PN}], [${PV}])" >> configure.ac | ||
echo "AM_INIT_AUTOMAKE" >> configure.ac | ||
echo "AC_CONFIG_SUBDIRS([${DIRS}])" >> configure.ac | ||
echo "AC_CONFIG_FILES([Makefile])" >> configure.ac | ||
echo "AC_OUTPUT()" >> configure.ac | ||
echo "SUBDIRS= ${DIRS}" >> Makefile.am | ||
sed -i \ | ||
-e "/^CFLAGS/d" \ | ||
*/configure.ac || die | ||
eautoreconf | ||
cd ${LIBDIR} | ||
rm libcn*.so || die | ||
ln -sf libcnbpcnclapicom2.so.5.0.0 libcnbpcnclapicom2.so || die | ||
ln -sf libcnbpnet20.so.1.0.0 libcnbpnet20.so || die | ||
ln -sf libcnbpnet30.so.1.0.0 libcnbpnet30.so || die | ||
ln -sf libcnnet2.so.1.2.4 libcnnet2.so || die | ||
|
||
cd - | ||
} | ||
|
||
src_configure() { | ||
LDFLAGS="-L"${S}"/${LIBDIR}" econf --enable-progpath="${EPREFIX}/usr/bin" | ||
} | ||
|
||
src_install() { | ||
default | ||
insinto /usr/share/ppd/cupsfilters | ||
doins ppd/*ppd | ||
dolib.so ${LIBDIR}/* | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters