Skip to content

Commit

Permalink
dev-libs/libuv: Version 1.23.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.46, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Aug 17, 2018
1 parent bf6ea77 commit e946723
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libuv/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST libuv-1.20.0.tar.gz 1180231 BLAKE2B 8ba258477c685acc1ed5486211b65719419757f
DIST libuv-1.20.3.tar.gz 1181741 BLAKE2B ee68f975c9f150034b02772b297a05692305155449dac75f35ca32761ffa2803385b22cce5c0fe1b2ad73a52144e6218e2c62d73c92e098017bee74a99e16062 SHA512 60ebc0059ec9fdd022aa9d60b2a0340f29e037bf79fa08707f6f2ecca9ec263c7a6466bdc1f94e0875a6a627ee749efa86117dedb22119676a7bafed8b5d77a0
DIST libuv-1.21.0.tar.gz 1187827 BLAKE2B e534eb4a7cdde3988a34047c999fd20e83f443bcf3ac1c62e07b7e4ddd95f62ac8221d58197b5f8fed618686d6003e35793b1b91e1dcfd6245a05d8bff1b881c SHA512 ab6b52f8bee1900953d9136e4d281f81ba9f14287760f7bfc8633289699cb9eeaab15d9146ed05b164631fcb3c2b5abcee8c10499d080a82a411bb1f02564c48
DIST libuv-1.22.0.tar.gz 1186080 BLAKE2B 5e909c36e5ff75fb199f52d5910bb092ca4117ca0c53f8d3e7c9dd7e57f4959dca6e46db095cca93f3a079850268e5cc0fc68b2916a20773f09b2ba5f1531cc0 SHA512 e79cae6aa1d9cf2c8f7c0262c866fea2858d7104ece7c556e537e7d1cf884f191d5cd3e56539bfe857fa15dc50b57fdcb33019824cd585a2ca250a77d923af73
DIST libuv-1.23.0.tar.gz 1189014 BLAKE2B 1bb2330773b8e7e7ee00e7000ea4076e0d93c3f54f7dc4e8ae0c6c73c652a406c907ee16a2364fc8688c7cc7a367fd3dab7a8b4885caf06a0196cb3d09fe7fb3 SHA512 d1622ea9c03661ce2dfa18e1725fc1bfdf3b16d7e40babc552dcc5b2f86d52f4dd81cac9bf89914024b11e4ed3671264dfcfba867cfa3b1a2206b89c59c95851
47 changes: 47 additions & 0 deletions dev-libs/libuv/libuv-1.23.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools ltprune multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
RESTRICT="test"

DEPEND="sys-devel/libtool
virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
default

echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
> m4/libuv-extra-automake-flags.m4 || die

eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
cc_cv_cflags__g=no
$(use_enable static-libs static)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
mkdir "${BUILD_DIR}"/test || die
cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
default
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files
}

0 comments on commit e946723

Please sign in to comment.