Skip to content

Commit

Permalink
games-fps/freedm-data: Version bump to 0.12.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/699266
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: William Breathitt Gray <[email protected]>
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
vilhelmgray authored and chewi committed Nov 7, 2019
1 parent 63b71db commit ea16759
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-fps/freedm-data/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST freedoom-0.12.0.tar.gz 18409554 BLAKE2B 01ae58c8edb12a8453f6026f09f45d54b19949d38f0668ddc6d4a6ee5fee4cc62c3926af0fb8e30e5f574b46ad1990fb20b57369821562851ae0cef0a6a5e5f1 SHA512 055cae8d16cc7ca2017eeabcaca9436da044def5f630ab46fb0c4cd7d36b9db3b416f9ddeb855e79f21f7c5337d25fb82625ac987712910daec448b49ef9c41e
DIST freedoom-0.12.1.tar.gz 18405081 BLAKE2B a508d9ce924ff10640d6017302864869efff474c89fe20a866082b565a1ce65182483a5a692c9ce3329b81472ae9e4fee4ac2511670ecb5dd06ccf81930ac70d SHA512 7db65b039ce98593a86a19b46efe629b85a339c4c020750c3abb95d226fca484c63686ab8c88ecc1e16e86a6aca3b8c7952d85103e0f3db07cc7204fa528daf2
57 changes: 57 additions & 0 deletions games-fps/freedm-data/freedm-data-0.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit prefix python-any-r1 xdg

DESCRIPTION="Game resources for FreeDM"
HOMEPAGE="https://freedoom.github.io"
SRC_URI="https://github.com/freedoom/freedoom/archive/v${PV}.tar.gz -> freedoom-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

BDEPEND="
$(python_gen_any_dep 'dev-python/pillow[${PYTHON_USEDEP}]')
app-text/asciidoc
games-util/deutex"

S="${WORKDIR}/freedoom-${PV}"

DOOMWADPATH=share/doom

python_check_deps() {
has_version -b "dev-python/pillow[${PYTHON_USEDEP}]"
}

src_prepare() {
xdg_src_prepare
eapply_user

hprefixify dist/freedoom
}

src_compile() {
emake wads/freedm.wad \
freedm.6 \
{NEWS,README}.html
}

src_install() {
emake install-freedm \
prefix="${ED}/usr/" \
bindir="bin/" \
docdir="share/doc/${P}" \
mandir="share/man/" \
waddir="${DOOMWADPATH}/"
}

pkg_postinst() {
xdg_pkg_postinst

elog "FreeDM WAD file installed into ${EPREFIX}/usr/${DOOMWADPATH} directory."
}

0 comments on commit ea16759

Please sign in to comment.