Skip to content

Commit

Permalink
x11-terms/xterm: Version bump to 329
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
mrueg committed Jun 19, 2017
1 parent 97b315b commit ea20c47
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-terms/xterm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST xterm-327.tgz 1240131 SHA256 66fb2f6c35b342148f549c276b12a3aa3fb408e27ab6360ddec513e14376150b SHA512 d9d9f3b870fea8db9ae3c076a9d85152488b2d392b9b1e2e4ebbeded287ed4911f1f63e5e035d5b3793b2506b993125c6fca437393b435a28aeb519d76147672 WHIRLPOOL 44254647e9e6e331d198763c5d38738ebf56386e9c93ee65beaf15ad5d0eb2f75731498608e1e9d503e7d2355a0a456336bcaa4b1d16ab791961cfa404a9489d
DIST xterm-328.tgz 1264517 SHA256 b38a7ab2e9f6ab51784ab82a312ca9950e0039da846d37715db4c1ddd47b1d52 SHA512 4f3381440394e0cd2d6c4d6645573ab2eac1c1c98e510eb0b3281ed4d2b1082e57ae58b7f756a03704eb275925ae497a1ae6c5907d6ba1b8ec95f92eaf939656 WHIRLPOOL 40e23e7c7a33376641bc8a95993bfbba371a32c39b86bd16f407e6fd60acb0164a981e3464d6c8ffcc9bc20881700480c0d3855b3ae4b32a9c8f13c19d7477da
DIST xterm-329.tgz 1265450 SHA256 1eb9f296240f2d1e3ea633023daa3410f8710854f0a1323a73e94de4c312891c SHA512 b6d68bde0796dc6848c02bb0f780b778226e110e7b495fd8c8d45870b1e78b1b91263a45748ef0fbfbd3a7262f4af78daeca07984c3f4cba4c5da67c4c3f0347 WHIRLPOOL 680a21b5038d0756bd6f9f3768e046161b552a7ce86d489d57ca8aaca40a2db21fa80b838419df88ec0a6072096d9f9dc26deb80a2dbea122b4b125d6601f05d
94 changes: 94 additions & 0 deletions x11-terms/xterm/xterm-329.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils flag-o-matic multilib

DESCRIPTION="Terminal Emulator for X Windows"
HOMEPAGE="http://invisible-island.net/xterm/"
SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="+openpty toolbar truetype unicode Xaw3d xinerama"

COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
>=sys-libs/ncurses-5.7-r7:0=
x11-apps/xmessage
x11-libs/libX11
x11-libs/libXaw
x11-libs/libXft
x11-libs/libxkbfile
x11-libs/libXmu
x11-libs/libXrender
x11-libs/libXt
unicode? ( x11-apps/luit )
Xaw3d? ( x11-libs/libXaw3d )
xinerama? ( x11-libs/libXinerama )"
RDEPEND="${COMMON_DEPEND}
media-fonts/font-misc-misc
x11-apps/rgb"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
x11-proto/kbproto
x11-proto/xproto"

DOCS=( README{,.i18n} ctlseqs.txt )

pkg_setup() {
DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
}

src_configure() {
# 454736
# Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
# something sane like pkg-config or ncurses5-config and stops guessing libs
# Everything gets linked against ncurses anyways, so don't shout
append-libs $(pkg-config --libs ncurses)

econf \
--libdir="${EPREFIX}"/etc \
--disable-full-tgetent \
--with-app-defaults="${DEFAULTS_DIR}" \
--disable-setuid \
--disable-setgid \
--with-utempter \
--with-x \
$(use_with Xaw3d) \
$(use_with xinerama) \
--disable-imake \
--enable-256-color \
--enable-broken-osc \
--enable-broken-st \
--enable-exec-xterm \
$(use_enable truetype freetype) \
--enable-i18n \
--enable-load-vt-fonts \
--enable-logging \
$(use_enable openpty) \
$(use_enable toolbar) \
$(use_enable unicode mini-luit) \
$(use_enable unicode luit) \
--enable-wide-chars \
--enable-dabbrev \
--enable-warnings
}

src_install() {
default

dohtml xterm.log.html
domenu *.desktop

# Fix permissions -- it grabs them from live system, and they can
# be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
# respectively (#69510).
# (info from Thomas Dickey) - Donnie Berkholz <[email protected]>
fperms 0755 /usr/bin/xterm

# restore the navy blue
sed -i -e "s:blue2$:blue:" "${D}${DEFAULTS_DIR}"/XTerm-color || die
}

0 comments on commit ea20c47

Please sign in to comment.