Skip to content

Commit

Permalink
dev-cpp/kokkos: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Christoph Junghans <[email protected]>
  • Loading branch information
junghans committed Apr 18, 2020
1 parent e5b4d91 commit ea22e4e
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/kokkos/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kokkos-3.0.00.tar.gz 1923287 BLAKE2B 4a2935e9388b3d577d6ce8678cad37830970222e6ce8a9c3db67633cb521440f14fdb380f03d3c77cd5ade85abe94aef97e9cc4949cc3a140fae958e0c15fff8 SHA512 c9daf62a2c92462c815aa241934aca5720bac8f88195635ae5a3ff4111d289a48898d32358b91e120756d3412820050297a76f44828f4cbc0b2b837a736e84aa
DIST kokkos-3.1.00.tar.gz 1972408 BLAKE2B 47c3eb83526dd13430a3b7049a98169d15ef73c6d2b3943c5600a153d28a9c6a0d6ee0b8eda1aac5f1b53556c5cee1680ce92a90f97b1b2741e1e7f0c9222486 SHA512 7933542c24e137052d630a503d707912295022863f2d47c89c4a35a9c8a70514763d89e321c66a3878575e661461ede45ac44d74cf45eca2470e7f57840d5c0c
45 changes: 45 additions & 0 deletions dev-cpp/kokkos/kokkos-3.1.00.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils toolchain-funcs

DESCRIPTION="Kokkos C++ Performance Portability Programming EcoSystem"
HOMEPAGE="https://github.com/kokkos"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+openmp test"
RESTRICT="!test? ( test )"

DEPEND="
sys-apps/hwloc
"
RDEPEND="${DEPEND}"
BDEPEND=""

pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]] && \
use openmp && ! tc-has-openmp ; then
die "Need an OpenMP capable compiler"
fi
}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_INCLUDEDIR=include/kokkos
-DKokkos_ENABLE_TESTS=$(usex test)
-DKokkos_ENABLE_AGGRESSIVE_VECTORIZATION=ON
-DKokkos_ENABLE_DEPRECATED_CODE=ON
-DKokkos_ENABLE_SERIAL=ON
-DKokkos_ENABLE_HWLOC=ON
-DKokkos_HWLOC_DIR="${EPREFIX}/usr"
-DKokkos_ENABLE_OPENMP=$(usex openmp)
-DBUILD_SHARED_LIBS=ON
)

cmake-utils_src_configure
}

0 comments on commit ea22e4e

Please sign in to comment.