forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-fonts/mplus-outline-fonts: new upstream release
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST mplus-TESTFLIGHT-062.tar.xz 10173592 BLAKE2B a2b202115d1b239bbbc76583261ed90d14a7ee9fba1542005fcdd995d9793fcf76352a32f4985ab6cbef60fb4e4d82c9aab030d68a78da752e1424f90c30af11 SHA512 c8c4a9419423c9e98a64e344db7bcbc3b2d6b1ef08219a445acc18a6c5d39bdf3216a827c20ed41b25368e792986937623de31579a9ece5109954db7f0dd6d9c | ||
DIST mplus-TESTFLIGHT-063.tar.xz 10346584 BLAKE2B d053992dc6b1220361f91d9482eeea11bc32ec1989ef9b99e178f3f229c84f1d232111b7a97df195473bd957eccc973a0233da5263038e6beaf4a9ff64ff0cd7 SHA512 477b9669c14dfb10321b5986dece72fb44a2554ff6c9239ccfadf21643714984ee7fd1e42c9c7982fa17417dee0e7ef6b5d66fc7cceec05298add4ae3d9502fa |
45 changes: 45 additions & 0 deletions
45
media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit font | ||
|
||
MY_P="mplus-${PV/0_pre/TESTFLIGHT-}" | ||
|
||
DESCRIPTION="M+ Japanese outline fonts" | ||
HOMEPAGE="http://mplus-fonts.osdn.jp/ http://ossipedia.ipa.go.jp/ipafont/" | ||
SRC_URI="mirror://sourceforge.jp/mplus-fonts/62344/${MY_P}.tar.xz" | ||
|
||
LICENSE="mplus-fonts ipafont? ( IPAfont )" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86 ~ppc-macos ~x86-macos" | ||
IUSE="ipafont" | ||
RESTRICT="binchecks strip" | ||
|
||
DEPEND="ipafont? ( | ||
media-gfx/fontforge | ||
media-fonts/ja-ipafonts | ||
)" | ||
RDEPEND="" | ||
S="${WORKDIR}/${MY_P}" | ||
|
||
FONT_SUFFIX="ttf" | ||
FONT_S="${S}" | ||
DOCS="README_J README_E" | ||
|
||
IPAFONT_DIR="${EPREFIX}/usr/share/fonts/ja-ipafonts" | ||
|
||
src_prepare() { | ||
if use ipafont; then | ||
cp -p "${IPAFONT_DIR}"/ipag.ttf "${S}" || die | ||
fi | ||
default | ||
} | ||
|
||
src_compile() { | ||
if use ipafont; then | ||
fontforge -script m++ipa.pe || die | ||
rm -f ipag.ttf | ||
fi | ||
} |