forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/restorecond: bump to 2.7_rc1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
58 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST restorecond-2.7-rc1.tar.gz 17752 SHA256 af97d65094dd0b064325647e63130737b6fb077de1753e0b6d2d4c8060b938d5 SHA512 386d62a42237288fbe013bcc05ce9d6b46007ca3c9c0671fd53e60203fb0a92e7911d80a27591f068c8038f390af7bd39b6b75244f944684186e7766a19e2fbd WHIRLPOOL 06e6ad4afe94e49b6d3040235da052a4e0641c8054e6b80236cc84c04ed477eb71e1a276c03e1ef9c7025b670ac55014ba4b64df336fd9681d68bb96c0ead2b2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit toolchain-funcs | ||
|
||
MY_RELEASEDATE="20170609" | ||
|
||
MY_P="${P//_/-}" | ||
IUSE="" | ||
|
||
if [[ ${PV} == *9999 ]] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git" | ||
S="${WORKDIR}/${MY_P}/${PN}" | ||
else | ||
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86" | ||
S="${WORKDIR}/${MY_P}" | ||
fi | ||
|
||
DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts" | ||
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
DEPEND=">=sys-libs/libsepol-${PV}:= | ||
>=sys-libs/libselinux-${PV}:= | ||
dev-libs/libpcre:= | ||
>=sys-libs/libcap-1.10-r10:=" | ||
|
||
RDEPEND="${DEPEND} | ||
!<sys-apps/policycoreutils-2.7_pre" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror" | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
LIBDIR="\$(PREFIX)/$(get_libdir)" | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" \ | ||
LIBDIR="\$(PREFIX)/$(get_libdir)" \ | ||
install | ||
|
||
rm -rf "${D}/etc/rc.d" || die | ||
|
||
newinitd "${FILESDIR}/restorecond.init" restorecond | ||
} |