Skip to content

Commit

Permalink
dev-python/aiohttp: Add new version 3.6.2
Browse files Browse the repository at this point in the history
Needed for net-misc/gns3-server-2.2.7

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Gino McCarty <[email protected]>
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
oniGino authored and zmedico committed May 4, 2020
1 parent dd2d78d commit eb5c652
Show file tree
Hide file tree
Showing 2 changed files with 133 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/aiohttp/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST aiohttp-3.6.1.tar.gz 1113678 BLAKE2B cfdf1c650ec52c7b6423f7afd40060ccd1631a407f126bf64c2a353c51f09c31bae3912b8ce9397c0c8350a2e82a98724ae58335998d1ab08ae46a49abce0251 SHA512 4939b89d45abcd655ef212ff87f66a83882fb12dffb87d62ae57afcd9517725af61f46f9b7428112e2dcd72d3a4027524967461270ede34348ff3ead47d14c9b
DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
132 changes: 132 additions & 0 deletions dev-python/aiohttp/aiohttp-3.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,132 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )

inherit distutils-r1

DESCRIPTION="http client/server for asyncio"
HOMEPAGE="https://pypi.org/project/aiohttp/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"

COMMON_DEPEND="
>=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
>=dev-python/yarl-1.0[${PYTHON_USEDEP}]
dev-python/idna-ssl[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
${COMMON_DEPEND}
dev-python/async_generator[${PYTHON_USEDEP}]
dev-python/brotlipy[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
www-servers/gunicorn[${PYTHON_USEDEP}]
>=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
)
"
RDEPEND="${COMMON_DEPEND}"

DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )

distutils_enable_sphinx docs \
'>=dev-python/alabaster-0.6.2' \
'dev-python/sphinxcontrib-asyncio' \
'dev-python/sphinxcontrib-blockdiag' \
'dev-python/sphinxcontrib-newsfeed' \
'dev-python/sphinxcontrib-spelling' \
'dev-python/sphinx' \
'dev-python/sphinx-aiohttp-theme'

distutils_enable_tests pytest || die "Tests fail with ${EPYTHON}"

python_prepare_all() {
sed -e 's|^async def test_aiohttp_request_coroutine(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_handle_keepalive_on_closed_connection(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_server_close_keepalive_connection(|@pytest.mark.xfail\n\0|' \
-i tests/test_client_functional.py || die

sed -e 's|^async def test_request_tracing_exception(|@pytest.mark.xfail\n\0|' \
-i tests/test_client_session.py || die

sed -e 's|^async def test_cleanup2(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_cleanup3(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_abort_closed_transports(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_cancels_cleanup_closed_handle(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_cancels_cleanup_handle(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_during_connect(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_twice(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_close_with_acquired_connection(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_queued_operation_tracing(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_reuseconn_tracing(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_with_limit(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_with_limit_and_limit_per_host(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_with_limit_concurrent(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_with_no_limit_and_limit_per_host(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_connect_with_no_limits(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_get(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_get_expired(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_get_expired_ssl(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_limit_per_host_property(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_limit_per_host_property_default(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_limit_property(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_limit_property_default(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_acquired(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_acquired_closed(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_already_closed(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_close_do_not_delete_existing_connections(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_not_started(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_ssl_transport(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_first_available(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_no_available(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_no_limit(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_per_host(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_release_first(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_release_waiter_skip_done_waiter(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_tcp_connector_dns_throttle_requests_cancelled_when_close(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_tcp_connector_do_not_raise_connector_ssl_error(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_tcp_connector_uses_provided_local_addr(|@pytest.mark.xfail\n\0|' \
-i tests/test_connector.py || die

sed -e 's|^ async def test_read_boundary_with_incomplete_chunk(| @pytest.mark.xfail\n\0|' \
-e 's|^ async def test_read_incomplete_chunk(| @pytest.mark.xfail\n\0|' \
-i tests/test_multipart.py || die

sed -e 's|^def test_aiohttp_plugin_async_fixture(|@pytest.mark.xfail\n\0|' \
-i tests/test_pytest_plugin.py || die

sed -e 's|^async def test_mixed_middleware(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_new_style_middleware_class(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_new_style_middleware_method(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_old_style_middleware(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_old_style_middleware_class(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_middleware.py || die

sed -e 's|^async def test_client_disconnect(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_protocol.py || die

sed -e 's|^async def test_partially_applied_handler(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_urldispatcher.py || die

distutils-r1_python_prepare_all
}

python_test() {
pytest -vv "${S}/tests" || die "Tests fail with ${EPYTHON}"
}

0 comments on commit eb5c652

Please sign in to comment.