Skip to content

Commit

Permalink
games-roguelike/dwarf-fortress: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.5
  • Loading branch information
Chris Reffett committed Dec 30, 2017
1 parent 25fe8ca commit eb76c2f
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
2 changes: 2 additions & 0 deletions games-roguelike/dwarf-fortress/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST df_43_05_linux.tar.bz2 11580594 BLAKE2B 7157f8ed5f8798a533d992811c804515acc8abb3bb84b25af6905fd6b2338e95879e318bec0dade18f1eba1421d17a781d1da8b49c719988d2cb6d7046b0c3be SHA512 502e6bac0bdd5586fb6b4e1117caf144a0336a7eed3ed9350ec316e4a286e309a15e0738517c0dd7d32f182984c501c7a8756e942d3dde9fb87f72b153f38e7a
DIST df_43_05_linux32.tar.bz2 12158550 BLAKE2B 4c1f5ad834aa0a2b6438b8aaf0b0ad6cfc60656f58845a274ac3d8ad7e09182d7263e3a495d1bff0b1fb5499097569216fac0bc87cff95fc6a85e3211acc297d SHA512 d0446ddb5c37ee45ade36b18b815595e8d7bfd9749af4ecd2f25b45859d797a9da70f2344e2c58544feafc7df06882ade8a10534c37754359747c0d37f084b7c
DIST df_44_03_linux.tar.bz2 11945628 BLAKE2B dd4fd2ce847a0214fc0ce49c84775a64c112354eb7cede8b4cc45390bd9c9f590f1295b0242009ed38284851494e50a6487414b5cecb5d84cf824f2a9f16dca4 SHA512 7f1ed0407414b6716b5a172a5b9cfc002462b68a86e7a3ad3774728922d1439b78a04bdd3b0a17d996c3777ef6e0b4274da83a417572b22813e1c93d3cd2ddde
DIST df_44_03_linux32.tar.bz2 12548954 BLAKE2B 8191806b3695562b4f6716fb2e090fd21a6d0cb9dedf1e812a9c18a7ca663112bf291f616c25fd53a92d14f1fdc586520b9c7a3493440bb3ec9f7c1c06e2cdcf SHA512 67312d2b29697d215f02f21ef3c08e9b012c24e43b17743a67610a47288e69a3eb9fe6a5ec56c9882c05412f889aed4de7bc3f2f98635d94ee805ba2328778cf
84 changes: 84 additions & 0 deletions games-roguelike/dwarf-fortress/dwarf-fortress-0.44.03.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit versionator

MY_PV=$(replace_all_version_separators _ "$(get_version_component_range 2-)")
MY_PN=df
MY_P=${MY_PN}_${MY_PV}

DESCRIPTION="A single-player fantasy game"
HOMEPAGE="http://www.bay12games.com/dwarves"
SRC_URI="amd64? ( http://www.bay12games.com/dwarves/${MY_P}_linux.tar.bz2 )
x86? ( http://www.bay12games.com/dwarves/${MY_P}_linux32.tar.bz2 )"

LICENSE="free-noncomm BSD BitstreamVera"
SLOT="0"
KEYWORDS="~amd64 ~x86 -*"
IUSE="debug"

RDEPEND="media-libs/glew:0
media-libs/libsdl[joystick,video]
media-libs/sdl-image[png]
media-libs/sdl-ttf
sys-libs/zlib
virtual/glu
x11-libs/gtk+:2"
# Yup, libsndfile, openal and ncurses are only needed at compile-time; the code
# dlopens them at runtime if requested.
DEPEND="${RDEPEND}
media-libs/libsndfile
media-libs/openal
sys-libs/ncurses:5[unicode]
virtual/pkgconfig"

S=${WORKDIR}/${MY_PN}_linux

gamesdir="/opt/${PN}"
QA_PREBUILT="${gamesdir#/}/libs/Dwarf_Fortress"
RESTRICT="strip"

src_prepare() {
rm -f libs/*.so* || die
sed -i -e '1i#include <cmath>' g_src/ttf_manager.cpp || die
default
}

src_configure() {
tc-export CXX PKG_CONFIG
CXXFLAGS+=" -D$(use debug || echo N)DEBUG"
}

src_compile() {
emake -f "${FILESDIR}/Makefile.native"
sed -e "s:^gamesdir=.*:gamesdir=${gamesdir}:" "${FILESDIR}/dwarf-fortress" > dwarf-fortress || die
}

src_install() {
# install data-files and libs
insinto "${gamesdir}"
doins -r raw data libs

# install our wrapper
dobin dwarf-fortress

# install docs
dodoc README.linux *.txt

fperms 755 "${gamesdir}"/libs/Dwarf_Fortress
}

pkg_postinst() {
elog "System-wide Dwarf Fortress has been installed to ${gamesdir}. This is"
elog "symlinked to ~/.dwarf-fortress when dwarf-fortress is run."
elog "For more information on what exactly is replaced, see /usr/bin/dwarf-fortress."
elog "Note: This means that the primary entry point is /usr/bin/dwarf-fortress."
elog "Do not run ${gamesdir}/libs/Dwarf_Fortress."
elog
elog "Optional runtime dependencies:"
elog "Install sys-libs/ncurses[unicode] for [PRINT_MODE:TEXT]"
elog "Install media-libs/openal and media-libs/libsndfile for audio output"
elog "Install media-libs/libsdl[opengl] for the OpenGL PRINT_MODE settings"
}

0 comments on commit eb76c2f

Please sign in to comment.