Skip to content

Commit

Permalink
sys-apps/net-tools: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Nov 24, 2015
1 parent 0acd7fa commit eb87504
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 2 deletions.
1 change: 1 addition & 0 deletions sys-apps/net-tools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST net-tools-1.60_p20130513023548-patches-2.tar.xz 14780 SHA256 4eba8545c64db6
DIST net-tools-1.60_p20130513023548.tar.xz 196684 SHA256 e4f47c0736c5d73853f3bbfd30bec1922465f7a2b5bce25e5067774bac1d716d SHA512 d01404ac461f93fbd304f6c67a8dcc642b833f3653b97a5c2ecf3774bfef8489d6aa5631dbefe432a6675e2ce20e88ce1b9888a9ec055198076970505afd1f1b WHIRLPOOL 24e5917bb790d683507d9406213e0ee0ca94c36fcca469ff0ab7fa4c30517cb29a4cfafb98fdedf3a4ba94baa3f66da48ae3a2f359e522b9d42e6e1c599772fa
DIST net-tools-1.60_p20141019041918-patches-1.tar.xz 3352 SHA256 12e79c866c532ba75c0367397f664799f90ab8901bc906429b67939e8e6b354f SHA512 139f8c2990e5be44c17c2c5c4a900d2d2a8cdb5c067a8fe822b20b964045a24bc1138f7656291bc4db80ecddaa24e2e2655c018925d7b214651284443df550f9 WHIRLPOOL 3e33a3d5e0209360c7d90e4741a1b2be662e3c9d1c8a1f8a7283bff98642934fd26da296c5ed4a064915fa1a1006ee8f94fedc07d86bda48ed9624fc9946d190
DIST net-tools-1.60_p20141019041918.tar.xz 197684 SHA256 22d1fb8acfa0b1e92d3c5dd3f544770b107df72f32f5b16232e65045c5efd2d0 SHA512 5fb02e181f3fec0a62a8ec8f1e6b0549d711d70d292491a2721d7f19f1a3b07d41fd0c8f503809435cd1a1b1999bcf5690402acc51f06ac6d626e11fef590e2e WHIRLPOOL c34f0c7363cc445e2457ccbf796947b60f74a063ed299840f755c6c023b8eb2cd46cdf42e1f9ca7530170e0b32dd14477e64ce50ec089e4a8b5d3e6bf65456ec
DIST net-tools-1.60_p20151124144947.tar.xz 227044 SHA256 fd771419c735ac43b27584594595e9bf8ee708aaf9948a44696ce9aa955e887d SHA512 0118af976ebc45edfd301c666fbf934c1fca1fd09396b6e3d09a8f9810809f7b765d6b3329044da5fccf96574b15b04fdedbaeac8e76e9811c0e87f53eff6530 WHIRLPOOL 33e1de04bc53ba16edc964b4f4b9393fbc2f474c423d73b565eb5449dfdb866edd275a16c08c25bd7eacbf8dff761e20f5eb13abd15c6af0062b6439fe439c5f
74 changes: 74 additions & 0 deletions sys-apps/net-tools/net-tools-1.60_p20151124144947.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit flag-o-matic toolchain-funcs

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/net-tools/code"
inherit git-2
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
fi

DESCRIPTION="Standard Linux networking tools"
HOMEPAGE="http://net-tools.sourceforge.net/"

LICENSE="GPL-2"
SLOT="0"
IUSE="ipv6 nls selinux static"

RDEPEND="!<sys-apps/openrc-0.9.9.3
selinux? ( sys-libs/libselinux )"
DEPEND="${RDEPEND}
selinux? ( virtual/pkgconfig )
app-arch/xz-utils"
if [[ ${PV} == "9999" ]]; then
DEPEND+=" nls? ( sys-devel/gettext )"
fi

maint_pkg_create() {
cd /usr/local/src/net-tools
#git-update
local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u +%Y%m%d%H%M%S)
local pv="${PV/_p*}_p${stamp}"; pv=${pv/9999/1.60}
local p="${PN}-${pv}"
git archive --prefix="${p}/" master | tar xf - -C "${T}"
pushd "${T}" >/dev/null
emake -C "${p}/po" dist
sed -i "/^RELEASE/s:=.*:=${pv}:" */Makefile || die
tar cf - ${p}/ | xz > ${p}.tar.xz
popd >/dev/null

du -b "${T}"/*.tar.xz
}

pkg_setup() { [[ -n ${VAPIER_LOVES_YOU} ]] && maint_pkg_create ; }

set_opt() {
local opt=$1 ans
shift
ans=$("$@" && echo y || echo n)
einfo "Setting option ${opt} to ${ans}"
sed -i \
-e "/^bool.* ${opt} /s:[yn]$:${ans}:" \
config.in || die
}

src_configure() {
set_opt I18N use nls
set_opt HAVE_AFINET6 use ipv6
set_opt HAVE_HWIB has_version '>=sys-kernel/linux-headers-2.6'
set_opt HAVE_HWTR has_version '<sys-kernel/linux-headers-3.5'
set_opt HAVE_HWSTRIP has_version '<sys-kernel/linux-headers-3.6'
set_opt HAVE_SELINUX use selinux
if use static ; then
append-flags -static
append-ldflags -static
fi
tc-export AR CC
yes "" | ./configure.sh config.in || die
}
8 changes: 6 additions & 2 deletions sys-apps/net-tools/net-tools-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="4"
EAPI="5"

inherit flag-o-matic toolchain-funcs

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://net-tools.git.sourceforge.net/gitroot/net-tools/net-tools"
EGIT_REPO_URI="git://git.code.sf.net/p/net-tools/code"
inherit git-2
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
Expand All @@ -26,6 +26,9 @@ RDEPEND="!<sys-apps/openrc-0.9.9.3
DEPEND="${RDEPEND}
selinux? ( virtual/pkgconfig )
app-arch/xz-utils"
if [[ ${PV} == "9999" ]]; then
DEPEND+=" nls? ( sys-devel/gettext )"
fi

maint_pkg_create() {
cd /usr/local/src/net-tools
Expand All @@ -35,6 +38,7 @@ maint_pkg_create() {
local p="${PN}-${pv}"
git archive --prefix="${p}/" master | tar xf - -C "${T}"
pushd "${T}" >/dev/null
emake -C "${p}/po" dist
sed -i "/^RELEASE/s:=.*:=${pv}:" */Makefile || die
tar cf - ${p}/ | xz > ${p}.tar.xz
popd >/dev/null
Expand Down

0 comments on commit eb87504

Please sign in to comment.