Skip to content

Commit

Permalink
net-im/skypeforlinux: Version bump to 8.65.0.78
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Oct 23, 2020
1 parent 0831b9b commit eb8fb2e
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/skypeforlinux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST skypeforlinux_8.65.0.76-1.x86_64.rpm 115113199 BLAKE2B b5f0fbb70849d3e6ec866b502b11d3b843ce25a27455e86a410c563f7de3b4961c843d461087b613581ebcecd0c79232552c4150684f6eb92eca779b4ffbad28 SHA512 6df1d3d98221ae9636a3f62d6acf0cb68376fce4b8abccbdf5d881092be91f337cc32323d263b708509e6f63bcfe4d0f4c9674ae106419de07acaf36e41434f2
DIST skypeforlinux_8.65.0.78-1.x86_64.rpm 115111132 BLAKE2B 2ec066763154a3479060d09e4d2106d04e8fdfe36361e27d85cf8605a675f6ca1db618f5a7d919686f39e1040f173c6bd028c11bea7eaff77801ea420272a948 SHA512 311805d46091d74104c0a87128c27ce61ba0a2401346d6aec1ee9f96c98912d1bbb087545b6ae69c77dc68ac800f27ea5e66c0eee624b2f28fcbbdcc196e68ba
98 changes: 98 additions & 0 deletions net-im/skypeforlinux/skypeforlinux-8.65.0.78.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MULTILIB_COMPAT=( abi_x86_64 )

inherit chromium-2 desktop pax-utils rpm multilib-build xdg

DESCRIPTION="Instant messaging client, with support for audio and video"
HOMEPAGE="https://www.skype.com/"
SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"

LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
SLOT="0"
KEYWORDS="-* ~amd64"

S="${WORKDIR}"
QA_PREBUILT="*"
RESTRICT="mirror bindist strip" #299368

RDEPEND="
app-crypt/libsecret[${MULTILIB_USEDEP}]
dev-libs/atk[${MULTILIB_USEDEP}]
dev-libs/expat[${MULTILIB_USEDEP}]
dev-libs/glib:2[${MULTILIB_USEDEP}]
dev-libs/nspr[${MULTILIB_USEDEP}]
dev-libs/nss[${MULTILIB_USEDEP}]
media-libs/alsa-lib[${MULTILIB_USEDEP}]
media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
media-libs/freetype:2[${MULTILIB_USEDEP}]
media-libs/libv4l[${MULTILIB_USEDEP}]
net-print/cups[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-devel/gcc[cxx]
virtual/ttf-fonts
x11-libs/cairo[${MULTILIB_USEDEP}]
x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
x11-libs/gtk+:3[${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
x11-libs/libXcomposite[${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXdamage[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXrender[${MULTILIB_USEDEP}]
x11-libs/libXtst[${MULTILIB_USEDEP}]
x11-libs/libxcb[${MULTILIB_USEDEP}]
x11-libs/libxkbfile[${MULTILIB_USEDEP}]
x11-libs/pango[${MULTILIB_USEDEP}]"

pkg_setup() {
chromium_suid_sandbox_check_kernel_config
}

src_unpack() {
rpm_src_unpack ${A}
}

src_prepare() {
default
sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
-i usr/bin/skypeforlinux || die
sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
-e "/^OnlyShowIn=/d" \
-i usr/share/applications/skypeforlinux.desktop || die
}

src_install() {
dodir /opt
cp -a usr/share/skypeforlinux "${ED}"/opt || die

# remove chrome-sandbox binary, users should use kernel namespaces
# https://bugs.gentoo.org/692692#c18
rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die

dobin usr/bin/skypeforlinux

dodoc usr/share/skypeforlinux/*.html
dodoc -r usr/share/doc/skypeforlinux/.
# symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
dosym ${PF} usr/share/doc/skypeforlinux

doicon usr/share/pixmaps/skypeforlinux.png

local res
for res in 16 32 256 512; do
newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
done

domenu usr/share/applications/skypeforlinux.desktop

pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
}

0 comments on commit eb8fb2e

Please sign in to comment.