forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mail-filter/imapfilter: upgrade to 2.7.5
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Stefan Strogin <[email protected]>
- Loading branch information
Showing
3 changed files
with
80 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST imapfilter-2.6.16.tar.gz 59636 BLAKE2B 9de58800ab88aa6e22ead001fd4e635b1991d23a2345d729a59438d3774148b1478b561c36848af155da7d15e84afdf900b73054ef268243f333843b71417d1e SHA512 0500931143e593eb69357ef6a6a40be971abadd22d7e807685b88927da8db9a928470f5cad460252b95ccd42efcfd39b5c4001a8796fa79cbd35018405a7be19 | ||
DIST imapfilter-2.7.5.tar.gz 59441 BLAKE2B 0326a698f3be18da47c99cbe20e5e51cde8abcaebf365b3f00e5b1dba6bfaed5139b65766bd447dc596736da504063d5c87c21d1c5c11d6bc7ebd947d9d44835 SHA512 a64747d745ecd5a2f61d486cd8fec1bceeb97ce459ec57454311a960dbfce526c15e8bddeb16860b8efd9710de93845adec61ec892355a0bef7bddc4517e1442 |
26 changes: 26 additions & 0 deletions
26
mail-filter/imapfilter/files/imapfilter-2.7.5-libressl.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
From 9a1132d8c8616b67156d49bea89d567ed31d42d6 Mon Sep 17 00:00:00 2001 | ||
From: Stefan Strogin <[email protected]> | ||
Date: Wed, 30 Dec 2020 06:48:40 +0300 | ||
Subject: [PATCH] Fix build with LibreSSL | ||
|
||
Signed-off-by: Stefan Strogin <[email protected]> | ||
--- | ||
src/socket.c | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/src/socket.c b/src/socket.c | ||
index aa2ef4f..fa75de4 100644 | ||
--- a/src/socket.c | ||
+++ b/src/socket.c | ||
@@ -143,7 +143,7 @@ open_secure_connection(session *ssn) | ||
goto fail; | ||
|
||
if (get_option_boolean("hostnames")) { | ||
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L | ||
+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER) | ||
SSL_set_hostflags(ssn->sslconn, | ||
X509_CHECK_FLAG_NO_PARTIAL_WILDCARDS); | ||
if (!SSL_set1_host(ssn->sslconn, ssn->server)) { | ||
-- | ||
2.30.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
LUA_COMPAT=( lua5-{1..3} ) | ||
|
||
inherit lua-single toolchain-funcs | ||
|
||
DESCRIPTION="An IMAP mail filtering utility" | ||
HOMEPAGE="https://github.com/lefcha/imapfilter" | ||
SRC_URI="https://github.com/lefcha/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
|
||
IUSE="libressl" | ||
|
||
REQUIRED_USE="${LUA_REQUIRED_USE}" | ||
|
||
RDEPEND=" | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
dev-libs/libpcre | ||
${LUA_DEPS}" | ||
DEPEND="${RDEPEND}" | ||
|
||
DOCS="AUTHORS NEWS README samples/*" | ||
|
||
PATCHES=( "${FILESDIR}"/${P}-libressl.patch ) | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "/^PREFIX/s:/usr/local:${EPREFIX}/usr:" \ | ||
-e "/^MANDIR/s:man:share/man:" \ | ||
-e "/^CFLAGS/s:CFLAGS =:CFLAGS +=:" \ | ||
-e "/^CFLAGS/s/-O//" \ | ||
src/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
LDFLAGS="${LDFLAGS}" \ | ||
INCDIRS=$(lua_get_CFLAGS) \ | ||
LIBLUA=$(lua_get_LIBS) | ||
} | ||
|
||
src_install() { | ||
default | ||
doman doc/imapfilter.1 doc/imapfilter_config.5 | ||
} |