Skip to content

Commit

Permalink
dev-ruby/omniauth: add 1.7.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.2
  • Loading branch information
graaff committed Sep 29, 2017
1 parent 01d5fd9 commit ebd907d
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/omniauth/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST omniauth-1.6.0.tar.gz 25205 SHA256 9eae49f049f47f646540d21c257b596a25179cd4466927362a97dc852fe4664c SHA512 fb989ba7aef74bd3d2c185d6401cf263ef6169abc3018f51ae7ed99921b9f339c60fc2735582f559a0e0726338bb8d114973588155239fde2bff5805ad520bc2 WHIRLPOOL 33a83c09a775297fdc9346530e0935ccdb7985075e9e520dd8e6d30eb16a33fcc69baa7d9479c12689755122452cff1c8cf1cb1e8f390da3270bb2900b8d6834
DIST omniauth-1.6.1.tar.gz 25094 SHA256 9a6cb873857f30468cff0024b73ead30ac46bd5da98be2db0b2e72a20b73f0d4 SHA512 5cb372ef4c8b78d5d110eb3f2f828ac3af5d14f230ed3a7d81f0464e21f0d3a434604fe2102874a3b6c341cbe9ad4db4af575229c77592c11e756bb38ab3b80b WHIRLPOOL b7711d6f5526e96e2d249cd2bc83e01b65d7fc8feb4f46bf660ce8f43979177168d9a9065876db6c9062f282907e6750649cfb350d1aa56cd7b3ec168f64e096
DIST omniauth-1.7.0.tar.gz 25918 SHA256 1b7175f3f1c3d24ee530c590aeca34f16f5e093cf8702efee735c0de38cb29bf SHA512 004475651fba1fe6e737eceb16a1bd89b510cd06d1bcf155dc56fc6793ad5e61755b80b827076583f6f72d17ada0223c22aac34c206cee4b250e5dd126f98fa7 WHIRLPOOL 1afc8fe1a1d645a5dbb32b34a0c692566be08eba7c9af1ff9bdcf784742f61154c2d0fb674b87bd265aa1aa200658d40cb5b8abfb652d04355532cefc7f223e1
46 changes: 46 additions & 0 deletions dev-ruby/omniauth/omniauth-1.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
HOMEPAGE="https://github.com/intridea/omniauth"
SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0"
IUSE=""

ruby_add_rdepend "
>=dev-ruby/rack-1.6.2:* <dev-ruby/rack-3:*
>=dev-ruby/hashie-3.4.6:3 <dev-ruby/hashie-3.6.0:3"
ruby_add_bdepend "doc? ( dev-ruby/yard )
test? ( dev-ruby/rack-test )"

all_ruby_prepare() {
sed -i -e '/[Bb]undler/d' \
Rakefile ${PN}.gemspec || die "sed failed"
sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
# maruku fails, resorting to default markdown implementation
sed -i -e '/maruku/d' .yardopts || die "sed failed"

sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_compile() {
all_fakegem_compile

if use doc ; then
yard || die "yard failed"
fi
}

0 comments on commit ebd907d

Please sign in to comment.