forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-cluster/kube-controller-manager: add 1.23.15
Signed-off-by: William Hubbs <[email protected]>
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST kubernetes-1.23.14.tar.gz 38259227 BLAKE2B eda8d6b2e40f869834d6fb8d750b7bfa402d2841564c8b4b102b5a94d8fc33601670f8671d81781bd4f6005ebc811e10b5365ae8c066ba04cfeb00f648156db6 SHA512 3464840aefbe4bfa510e575374d4a4a5ff8efb3b30e5d8f915f18351e7c20014dec109050f697c91c58dc4e3abefbe54524f2bf8683af4b05ca28013ad8cf73f | ||
DIST kubernetes-1.23.15.tar.gz 38273440 BLAKE2B d08b420cb31ddba2b70830d7f2c9fa44d63142f999407f17260807c0a394bce66bd2cf4e0ff2568c94549882bed2d0c8812031c433396a0490f7d70d9e350a32 SHA512 06c63c0abd880893ffda4e9b7216520d13278740461808ea0b01495998f6ddcbe57c32f2fe861e0fe1ee86a4ccf3431f4babc612085681d35c94b3fac54af199 | ||
DIST kubernetes-1.24.8.tar.gz 38001022 BLAKE2B 8452e3b93f91c5b2c542a9fcd0843e36a87dfb366dc46af1602f349d0d22eb5a838bd0b26c9b394acc9d3af9b77eaf1a47380951750887b416f533414af1f1e5 SHA512 cb5b9fd2ffdf5a3de48aed0c6c50e874c09374021bf47072337c6ba9df5807fcf1ae37f594b74ecfd8cb31ededde0922093a25eb3c62b9e26b500830ea1af956 | ||
DIST kubernetes-1.25.4.tar.gz 38068572 BLAKE2B 66dfe5a55ded66fc00792accaed542e45bea65c659a676920fca13d70077db8f05149bf5922eef2c2811eea84932c6b9e4997969b90b97597146ec443420da3a SHA512 1cbd7b708a70dd51fe399924ea3d995c809e426a2946eaf50eda041ece7a4740513c54ac871270d2f4d7497f59b551a78e5cb6ecb991d4ba038972c7b7383cac |
38 changes: 38 additions & 0 deletions
38
sys-cluster/kube-controller-manager/kube-controller-manager-1.23.15.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit go-module | ||
|
||
DESCRIPTION="Kubernetes Controller Manager" | ||
HOMEPAGE="https://kubernetes.io" | ||
SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64" | ||
IUSE="hardened" | ||
|
||
COMMON_DEPEND="acct-group/kube-controller-manager | ||
acct-user/kube-controller-manager" | ||
DEPEND="${COMMON_DEPEND}" | ||
RDEPEND="${COMMON_DEPEND}" | ||
BDEPEND=">=dev-lang/go-1.17" | ||
|
||
RESTRICT+=" test" | ||
S="${WORKDIR}/kubernetes-${PV}" | ||
|
||
src_compile() { | ||
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \ | ||
emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN} | ||
} | ||
|
||
src_install() { | ||
dobin _output/bin/${PN} | ||
newinitd "${FILESDIR}"/${PN}.initd ${PN} | ||
newconfd "${FILESDIR}"/${PN}.confd ${PN} | ||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}"/${PN}.logrotated ${PN} | ||
keepdir /var/log/${PN} | ||
fowners ${PN}:${PN} /var/log/${PN} | ||
} |