Skip to content

Commit

Permalink
dev-python/pikepdf: Bump to 8.7.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
mgorny committed Nov 13, 2023

Verified

This commit was signed with the committer’s verified signature. The key has expired.
mgorny Michał Górny
1 parent 4516d31 commit ebe936d
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pikepdf/Manifest
Original file line number Diff line number Diff line change
@@ -3,3 +3,4 @@ DIST pikepdf-8.5.1.tar.gz 2854559 BLAKE2B 70bca735461d0234cd43cc757a1e8137f9cc30
DIST pikepdf-8.5.2.tar.gz 2854729 BLAKE2B 276d96d21e0d5d58177776257286560771896424dd49145cf5daf32bd6344a0d18b22ca4a0ee806d1aabdef3310a751a091f9a6f4725199d04dab689ea678546 SHA512 7f107ed1535e876c1892d3ffdae57fca85c140ff2fdd981937600b310692248c53a3539dc8c1c1c5ce6e35349692d67c6c4e2f31a3a74ead246faaa212bd70d4
DIST pikepdf-8.5.3.tar.gz 2854900 BLAKE2B 6dfd458b96b60cbd2cbd5491353c98710bec458b11f92b8e5abdad05a83567f98e0c21eeafd47650de0d6600f958417d92f62d76034db6663555fc76d8c4714b SHA512 dd7c6d131f1bf61c0cb285c06629c44a5e8436fa368832aacac7d5fcd8ab3b19b96d0d1005b02dd5084a1d9a4200f3fb27f66b60e9625f3cd9bfb32a649f497c
DIST pikepdf-8.6.0.tar.gz 2855625 BLAKE2B f9f0867b72e531c54bd65e0ce74eeea3b5379b04c073863b1e690e989f9d05061635eadb10ca0bb6f79f64e3d16d619b7c1200a35dfbfc8808831960c889e474 SHA512 d272b7f8c334a7c803594a6d7ace2d53a971da0ec1e814d16f20564af5075dbff35e1e28e129dcc2168d1c9b83047a9ea1905b163b24d14179cbd2dc874f84d7
DIST pikepdf-8.7.0.tar.gz 2860417 BLAKE2B bc11b2f1e2023cd25103e78522429cd50a6deae4e598653f6b9e35c82ac2069403c0fd8d17e56597c7189b207dd41dc8ecf23a940095625e19c453695e0290df SHA512 445c6cbd1b311ebfc96924cb5f381fe05ab549826029a796d7b744b93265880b27fe17e9f9cba212c5ed289a5fe6efa5e6457d0912f0ca13109c345d40e20ec7
62 changes: 62 additions & 0 deletions dev-python/pikepdf/pikepdf-8.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )

inherit distutils-r1 pypi

DESCRIPTION="Python library to work with pdf files based on qpdf"
HOMEPAGE="
https://github.com/pikepdf/pikepdf/
https://pypi.org/project/pikepdf/
"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"

# Check QPDF_MIN_VERSION in pyproject.toml on bumps, as well as
# https://qpdf.readthedocs.io/en/stable/release-notes.html.
DEPEND="
>=app-text/qpdf-11.5.0:0=
"
RDEPEND="
${DEPEND}
dev-python/deprecated[${PYTHON_USEDEP}]
>=dev-python/lxml-4.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
>=dev-python/pillow-10.0.1[${PYTHON_USEDEP}]
"
BDEPEND="
>=dev-python/pybind11-2.10.1[${PYTHON_USEDEP}]
>=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
test? (
>=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
>=dev-python/hypothesis-6.36[${PYTHON_USEDEP}]
>=dev-python/numpy-1.21.0[${PYTHON_USEDEP}]
>=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
>=dev-python/psutil-5.9[${PYTHON_USEDEP}]
>=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
>=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/tomli[${PYTHON_USEDEP}]
' 3.10)
)
"

distutils_enable_tests pytest

EPYTEST_DESELECT=(
# fragile to system load
tests/test_image_access.py::test_random_image
)

src_prepare() {
sed -e '/-n auto/d' -i pyproject.toml || die
distutils-r1_src_prepare
}

0 comments on commit ebe936d

Please sign in to comment.