Skip to content

Commit

Permalink
app-i18n/poedit: Version bump. Switch to GTK+3.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Ryan Hill <[email protected]>
  • Loading branch information
dirtyepic committed Apr 24, 2016
1 parent 7ab59e7 commit ec3a3f3
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-i18n/poedit/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST poedit-1.5.5.tar.gz 2594758 SHA256 3c94c9825c11a2d1ce10e083ad246e8625469f358da4a5a2f6210170b970f949 SHA512 a3524e27681dbf97babef7bf3ec56d6b7cd736370f8ed86b53c717a5a2eb36245f9ed89fcd28b57bd4d6f5ff5fb98d6c1615baae0bf10be720dcfdafa57ad4f4 WHIRLPOOL 893795acc85183cede0313b9220179cafa17a92033e8472e48454475f4ecdf51a014dc7123e9396a38a98217c43666919e7a1dadf68ab2f401b920071cec3d23
DIST poedit-1.8.3.tar.gz 2319253 SHA256 2a73c659506c31eac142ad5b070a2370a797f3e81813c915bdd75fac2dd21ec1 SHA512 c09faf18c9e58b2f4547e47d22a2237589eb4663985d0d3411e6f83691c34d075bff188fc14a9e245efe89d976377956d604c7f09d0329ddcd70383243f0f6b0 WHIRLPOOL 31b324c4c5b731836865c7bd464003b38406bf114f39354e9c6cb2bcfb65d5a3dead3e05ba780d2f0e13d504368d40e365f6372b6c9d5493814e063dd77a0bdf
DIST poedit-1.8.5.tar.gz 2404829 SHA256 cf541b8cbaf5d019cb2bd8f97c848e9f2d59dcf771d2281fc08f1122a923d96d SHA512 87eae2bcedc07eefb097edf263db10b3947956cfa504eddb259e3c3cfed6215ad0da4517fe5132b61041c39a7fbabd298ca42582570295bacbbd62d5ffc6f6a7 WHIRLPOOL 316e0593e2e5fa82c893f9b55ab0b8b2816a65f33e64f0b25985704c05c8d5d319cea4199c3c9685c57a0fbd96ace26f091214aab66a02dfc858759be8d7d99d
DIST poedit-1.8.7.tar.gz 2483945 SHA256 562d9fdf44869db63ad5c219a79aeecda859490d57e43e00140b0e8114006a46 SHA512 609022e696915cddb130c561c7eaa7dff76ce0458f58d9b8de34f0e8b98839cdccaf4a593e0e4eded67252cece08c61f961191f64cf4d76fa148f403d9705e68 WHIRLPOOL 8d1b7eafa8605323d8e4048e07eb631cac65eb2f98bdbe61687cb18c79120ac12187c6be60f112695b624857f0483c9fb6ec5e581691cb07cd14dcd30728d09e
67 changes: 67 additions & 0 deletions app-i18n/poedit/poedit-1.8.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
WX_GTK_VER=3.0-gtk3

PLOCALES="af am an ar ast az be be@latin bg bn br bs ca ca@valencia ckb co cs da de el en_GB eo es et eu fa fi fr fur fy_NL ga gl he hi hr hu hy id is it ja ka kab kk ko ky lt lv mk mn mr ms nb ne nl nn oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv ta tg th tr tt ug uk ur uz vi wa zh_CN zh_TW"

inherit fdo-mime l10n wxwidgets

DESCRIPTION="GUI editor for gettext translations files"
HOMEPAGE="https://poedit.net"
SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}-oss/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""

# db/expat req for legacytm (backwards support for pre 1.6)
# we currently have 1.5.5 in stable so this is enabled
RDEPEND="
app-text/gtkspell:3
dev-cpp/lucene++
dev-libs/boost:=[nls]
dev-libs/expat
dev-libs/icu:=
|| (
=sys-libs/db-5*:=[cxx]
=sys-libs/db-4*:=[cxx]
)
x11-libs/gtk+:3
x11-libs/wxGTK:${WX_GTK_VER}[X]
"

DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
my_rm_loc() {
sed -i -e "/^POEDIT_LINGUAS = /s: ${1}::" locales/Makefile.in || die
rm "locales/${1}.mo" || die
}
l10n_find_plocales_changes 'locales' '' '.mo'
l10n_for_each_disabled_locale_do my_rm_loc

setup-wxwidgets
default
}

src_configure() {
econf --without-cpprest --without-cld2
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS NEWS README
}

pkg_postinst() {
fdo-mime_desktop_database_update
}

pkg_postrm() {
fdo-mime_desktop_database_update
}

0 comments on commit ec3a3f3

Please sign in to comment.