forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-kernel/hardened-sources: version bump to 4.5.7-r4
vanilla-4.5.7 + genpatches-4.5-9 + grsecurity-3.1-4.5.7-201606262019 Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
45 changes: 45 additions & 0 deletions
45
sys-kernel/hardened-sources/hardened-sources-4.5.7-r4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
ETYPE="sources" | ||
K_WANT_GENPATCHES="base" | ||
K_GENPATCHES_VER="9" | ||
K_DEBLOB_AVAILABLE="1" | ||
|
||
inherit kernel-2 | ||
detect_version | ||
|
||
HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-5" | ||
HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2" | ||
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}" | ||
|
||
UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2" | ||
UNIPATCH_EXCLUDE=" | ||
1500_XATTR_USER_PREFIX.patch | ||
2900_dev-root-proc-mount-fix.patch" | ||
|
||
DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})" | ||
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/" | ||
IUSE="deblob" | ||
|
||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
|
||
RDEPEND=">=sys-devel/gcc-4.5" | ||
|
||
pkg_postinst() { | ||
kernel-2_pkg_postinst | ||
|
||
local GRADM_COMPAT="sys-apps/gradm-3.1*" | ||
|
||
ewarn | ||
ewarn "Users of grsecurity's RBAC system must ensure they are using" | ||
ewarn "${GRADM_COMPAT}, which is compatible with ${PF}." | ||
ewarn "It is strongly recommended that the following command is issued" | ||
ewarn "prior to booting a ${PF} kernel for the first time:" | ||
ewarn | ||
ewarn "emerge -na =${GRADM_COMPAT}" | ||
ewarn | ||
} |