Skip to content

Commit

Permalink
dev-python/numpy: fix build with recent distutils-r1 change
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/717706
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
floppym committed Apr 16, 2020
1 parent b6b1643 commit ec5de28
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From b8e741c66f71071c3406e592e1537570731bcb35 Mon Sep 17 00:00:00 2001
From: mattip <[email protected]>
Date: Sun, 26 May 2019 08:55:53 +0300
Subject: [PATCH] BUG: setup.py install --skip-build fails

---
numpy/distutils/command/install_clib.py | 3 +++
1 file changed, 3 insertions(+)

diff --git a/numpy/distutils/command/install_clib.py b/numpy/distutils/command/install_clib.py
index 662aa00bda9..6a73f7e3308 100644
--- a/numpy/distutils/command/install_clib.py
+++ b/numpy/distutils/command/install_clib.py
@@ -19,6 +19,9 @@ def finalize_options(self):

def run (self):
build_clib_cmd = get_cmd("build_clib")
+ if not build_clib_cmd.build_clib:
+ # can happen if the user specified `--skip-build`
+ build_clib_cmd.finalize_options()
build_dir = build_clib_cmd.build_clib

# We need the compiler to get the library name -> filename association
1 change: 1 addition & 0 deletions dev-python/numpy/numpy-1.16.5.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -41,6 +41,7 @@ BDEPEND="app-arch/unzip

PATCHES=(
"${FILESDIR}"/${PN}-1.15.4-no-hardcode-blas.patch
"${FILESDIR}"/numpy-1.16.5-setup.py-install-skip-build-fails.patch
)

src_unpack() {
Expand Down

0 comments on commit ec5de28

Please sign in to comment.