forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/numpy: fix build with recent distutils-r1 change
Closes: https://bugs.gentoo.org/717706 Signed-off-by: Mike Gilbert <[email protected]>
- Loading branch information
Showing
2 changed files
with
24 additions
and
0 deletions.
There are no files selected for viewing
23 changes: 23 additions & 0 deletions
23
dev-python/numpy/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
From b8e741c66f71071c3406e592e1537570731bcb35 Mon Sep 17 00:00:00 2001 | ||
From: mattip <[email protected]> | ||
Date: Sun, 26 May 2019 08:55:53 +0300 | ||
Subject: [PATCH] BUG: setup.py install --skip-build fails | ||
|
||
--- | ||
numpy/distutils/command/install_clib.py | 3 +++ | ||
1 file changed, 3 insertions(+) | ||
|
||
diff --git a/numpy/distutils/command/install_clib.py b/numpy/distutils/command/install_clib.py | ||
index 662aa00bda9..6a73f7e3308 100644 | ||
--- a/numpy/distutils/command/install_clib.py | ||
+++ b/numpy/distutils/command/install_clib.py | ||
@@ -19,6 +19,9 @@ def finalize_options(self): | ||
|
||
def run (self): | ||
build_clib_cmd = get_cmd("build_clib") | ||
+ if not build_clib_cmd.build_clib: | ||
+ # can happen if the user specified `--skip-build` | ||
+ build_clib_cmd.finalize_options() | ||
build_dir = build_clib_cmd.build_clib | ||
|
||
# We need the compiler to get the library name -> filename association |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters