forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST libbson-0.98.0.tar.gz 4451923 SHA256 5e792a3c4d296a8b9e4316f1c58e94819223c4512ba4a790cf9e7086ef614995 SHA512 9bae7593198c8ac358978bd6a065d65fb872a15fd43d11839ad5dff1ffbe0362b06cd4bde08032a2c11e8633789328b5d504cd032b7636dc525f6df3e6fd641d WHIRLPOOL ed6350ef59fa596f6414010362999896648c491a906b4ad9f5e11bac549acf975083d3b6ea8d4e0eff0e3ae35a7db784303120d3855b7f2bb21373a318f44516 | ||
DIST libbson-1.1.10.tar.gz 4431658 SHA256 211a62a7a6f93ba21b85afc1522c3a367a264be09626ea15f7be3a0fbe084a70 SHA512 636178bafb19e7b103b5192866dbda0c70b8d7173560b0466f88b3a85cce3292a7caac9521808fa8c09d187f8c96564dcd9fb787e855d1619610f813583379bc WHIRLPOOL 8b29882ce3ebe0da4b0ce952d2b79fff2ce4c211047ff7c05e15f6263546258c134974fdf539ed6173f286c501085e575cebde806f6578ea9fb843f1b92da4f3 | ||
DIST libbson-1.1.2.tar.gz 4492014 SHA256 acd8026d4e5bf5034b699af136236a8a38c06613d1800fdf54721fe66280b6ae SHA512 03e2ee337445286c14b846cd7545707959b1d351fa466c6292379a85e48ea1a171dae37dd7aff092212239ad59aac6f1ab216ee5de74ef00a8a2a124559e34da WHIRLPOOL 10a4fee34bcc12a730899553d62405784673ee5beecf63a624fb1527c9dddd0403d855a7557f6a35167bffee2b2ebb9f7d3b7ddc64d2e12cc39d95afe89e0db6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit autotools eutils | ||
|
||
DESCRIPTION="A BSON utility library" | ||
HOMEPAGE="https://github.com/mongodb/libbson" | ||
SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~hppa ~x86" | ||
IUSE="debug examples static-libs" | ||
|
||
RDEPEND="" | ||
DEPEND="${RDEPEND}" | ||
|
||
DOCS=( AUTHORS NEWS README ) | ||
|
||
src_prepare() { | ||
# https://github.com/mongodb/mongo-c-driver/issues/54 | ||
sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/bson/Makefile.am \ | ||
tests/Makefile.am || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf --disable-hardening \ | ||
--disable-optimizations \ | ||
$(use_enable debug) \ | ||
$(use_enable static-libs static) | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install | ||
doman doc/*.3 | ||
|
||
use static-libs || find "${D}" -name '*.la' -delete | ||
|
||
if use examples; then | ||
insinto /usr/share/${PF}/examples | ||
doins examples/*.c | ||
fi | ||
} |