Skip to content

Commit

Permalink
dev-python/passlib: rev-bump for py-3.5 compat and EAPI-6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
dev-zero committed Mar 16, 2016
1 parent e952e9a commit eca4953
Showing 1 changed file with 31 additions and 0 deletions.
31 changes: 31 additions & 0 deletions dev-python/passlib/passlib-1.6.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )

inherit distutils-r1

DESCRIPTION="Password hashing framework supporting over 20 schemes"
HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"

LICENSE="BSD-2"
KEYWORDS="~amd64 ~arm64 ~x86"
SLOT="0"
IUSE="test doc"

RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"

python_test() {
nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all
use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
}

0 comments on commit eca4953

Please sign in to comment.