Skip to content

Commit

Permalink
dev-db/tinycdb: new upstream release
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-2.3.23
Signed-off-by: Akinori Hattori <[email protected]>
  • Loading branch information
hattya committed Sep 2, 2020
1 parent 75cb851 commit ecb6edf
Show file tree
Hide file tree
Showing 3 changed files with 57 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-db/tinycdb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tinycdb-0.78.tar.gz 36754 BLAKE2B 41f4256840645acd28296c5473087c7cf4c026f068310375b3c305430c030b1c946f53fd3e09967d77b592ba84e7e56518fdb18e54d1e0f5e7dd552a1664a0ec SHA512 8930086b8e7fddcd4dbd3354c5f5ee05171df68fde1cc222b6c402430042b6e761efbad7e5fa8de18e1d36390f1526cc3e605c5086fe1c363ba1df6c03201553
DIST tinycdb_0.77.tar.gz 37728 BLAKE2B bebcc6128b253fa9e64438ed2671488153d70cf452bd0686a90ebd5360b725ab784b4537b25fe2ea9de0281cb1bb2fa29beb5f3515aed90fd7e2965f7e5e38bd SHA512 cfc830578a9be49781a1dbade97b64ec13293853093719aeb9a403c128245f157fd1d2d7e6941966bdea00b472127f10f11672583ba06ccc6e49151b22bf4c9a
7 changes: 4 additions & 3 deletions dev-db/tinycdb/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Akinori Hattori</name>
</maintainer>
</pkgmetadata>
52 changes: 52 additions & 0 deletions dev-db/tinycdb/tinycdb-0.78.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit toolchain-funcs

DESCRIPTION="A very fast and simple package for creating and reading constant data bases"
HOMEPAGE="http://www.corpit.ru/mjt/tinycdb.html"
SRC_URI="http://www.corpit.ru/mjt/${PN}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~x86"
IUSE="static-libs"
RESTRICT="test"

RDEPEND="!dev-db/cdb"

PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
"${FILESDIR}"/${PN}-uclibc.patch
)

src_prepare() {
default

sed -i "/^libdir/s:/lib:/$(get_libdir):" Makefile
}

src_compile() {
local targets="shared"
use static-libs && targets+=" staticlib piclib"

emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
${targets}
}

src_install() {
local targets="install install-sharedlib"
use static-libs && targets+=" install-piclib"

emake \
prefix="${EPREFIX}"/usr \
mandir="${EPREFIX}"/usr/share/man \
DESTDIR="${D}" \
${targets}
einstalldocs
}

0 comments on commit ecb6edf

Please sign in to comment.