Skip to content

Commit

Permalink
dev-lang/execline: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Jan 13, 2016
1 parent 2a8ec5d commit ecf3480
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/execline/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST execline-2.1.1.0.tar.gz 75967 SHA256 9e1a9b95772b64bd623c1ddea6200909cca0eb659893ac47857848928eaff7dc SHA512 250fe449b39a198193f1431b249b342f3c6c499fea12779a55d0e27aec2095285bbf9dc2a48d84eebdf9f540ecf5e67ef39393243ca0fadfc764d2cc95ac0b6b WHIRLPOOL ce92f6d7786e5f1efcfb5298b1fa8a561957c6b9f542ace49b815e69f98da4f88adcd339f7210d61d7ae1298573cd9bc31c22c6f7b3c8ac30f44986c88241f32
DIST execline-2.1.4.5.tar.gz 80203 SHA256 ab4451d4992a5d7fb2ae34cffe4d0806e4902bf9aa27ee3b75617aa35379356f SHA512 15a76c73afe98142b9f466edb442cad06ee69f0f0e15ad6a325c37f3878b4c5863b5cece67bd169e84b465a0f7f4f38f87fa88b2aa96fe40a20ebc3575a1ceb9 WHIRLPOOL 1df5b72f02c95d3fd24ff7c46b3cd7aff89186bfe6bb27df815f5bb06a12886e57b3fe67ff18d2d387dccb107eb8acf0b09124eafe47a9857e636d240e1051e8
55 changes: 55 additions & 0 deletions dev-lang/execline/execline-2.1.4.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 2013-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit multilib

DESCRIPTION="a non-interactive scripting language similar to SH"
HOMEPAGE="http://www.skarnet.org/software/execline/"
SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static static-libs"

DEPEND=">=sys-devel/make-4.0
static? ( >=dev-libs/skalibs-2.3.8.3[static-libs] )
!static? ( >=dev-libs/skalibs-2.3.8.3 )
"
RDEPEND="!static? ( >=dev-libs/skalibs-2.3.8.3 )"

src_prepare() {
# Remove QA warning about LDFLAGS addition
sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
}

src_configure()
{
econf \
$(use_enable static-libs static) \
$(use_enable static allstatic) \
$(use_enable !static shared) \
--bindir=/bin \
--sbindir=/sbin \
--dynlibdir=/$(get_libdir) \
--libdir=/usr/$(get_libdir)/${PN} \
--datadir=/etc \
--sysdepdir=/usr/$(get_libdir)/${PN} \
--with-dynlib=/$(get_libdir) \
--with-lib=/usr/$(get_libdir)/skalibs \
--with-sysdeps=/usr/$(get_libdir)/skalibs
}

src_compile()
{
emake DESTDIR="${D}"
}

src_install()
{
default
dohtml -r doc/*
}

0 comments on commit ecf3480

Please sign in to comment.