Skip to content

Commit

Permalink
dev-perl/Alien-wxWidgets: Fix use of wxwidgets eclass
Browse files Browse the repository at this point in the history
EAPI5 auto-setup the wxwidgets magic, but EAPI6 requires explicit
invocation to function.

This omission means Alien-wxWidgets would get built with whatever was
currently selected with "eselect wxwidgets", ultimately resulting in
compilation failure in dev-perl/Wx when the wx implementation was
either wxGTK 2.8, or the GTK3 version of wxGTK3

Bug: https://bugs.gentoo.org/623042
Bug: https://bugs.gentoo.org/627180
Bug: https://bugs.gentoo.org/615246
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
kentfredric committed Mar 21, 2018
1 parent fff0a28 commit ed08a23
Showing 1 changed file with 37 additions and 0 deletions.
37 changes: 37 additions & 0 deletions dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.690.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

WX_GTK_VER=3.0
DIST_AUTHOR=MDOOTSON
DIST_VERSION=0.69
inherit wxwidgets perl-module

DESCRIPTION="Building, finding and using wxWidgets binaries"

SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="gstreamer opengl test"

RDEPEND="
>=x11-libs/wxGTK-3:3.0[gstreamer=,opengl=,tiff,X]
>=dev-perl/Module-Pluggable-2.600.0
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-CBuilder-0.24
>=virtual/perl-File-Spec-1.500.0
>=dev-perl/Module-Build-0.280.0
test? ( virtual/perl-Test-Simple )
"

src_configure() {
setup-wxwidgets
myconf=( --wxWidgets-build=0 )
perl-module_src_configure
}

src_test() {
perl_rm_files t/zz_pod.t t/zy_pod_coverage.t
perl-module_src_test
}

0 comments on commit ed08a23

Please sign in to comment.