forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/retext: Version bump to 3.5.1
Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
51 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST ReText-4.1.3.tar.gz 129283 SHA256 bb4409982d27ac62cab01b0748fe41d9c6660853668b350f3369e76d155edd6c SHA512 d2b3fa901afa9870f6cecc7ab3126b91f1420ca1b14ddd4f609c2ada7121388840b5be679914694664f3bbf876ee8522aa6b0c82a23f837844f788fa10a46323 WHIRLPOOL 3be71e5d7ec612ae4e4fec17ca544f6d0e7cb7421fcdeb517d3c13156ed07f5e5e7c3e352cf604bfb5f2287964fdc173a1bac0eeab41ee1cda8b265ad0f57686 | ||
DIST ReText-5.2.1.tar.gz 157119 SHA256 02164ae2bba6f47a2ec5e11aa06aefbcd96bea1b84a96c5673dbe18d8ccb2a69 SHA512 1d11f6824b64a082425ac2e8b67da15d4df5352539b66a8297dba0cd4f4236b7328966e97104c3fd7a641067a84023f65ba856f932d8489ff4e80722471835d8 WHIRLPOOL 24e7c756f61c210320b0ab9a67c99f43ccf5739310a01d9ee98d779e8b45b27dbc828b0c573973b2e4d2b8e07f2edd56660de685930a7a2ed8ceb50ab6fb6f91 | ||
DIST ReText-5.3.0.tar.gz 160163 SHA256 9ec0cee93e6731fbf00b86574cb47c3132f62291e762f5e47258a3171bfdd21d SHA512 d6ff8e61b1e13de72c5d1741795fddb3a1ba443b2aa6aba6ca933ae38e09c8dac38085bfd73e0c1773dec9a72df1f08d64ef22d2396694530bade6ff8a485223 WHIRLPOOL 98537b5244a583c04604a6b1626a3813b6506dfefda6d40c85aaae076b30c7e14a0b8a363e431d9bd5ceea41a31f07785663a018bbdae1dc897a29eec22c99c1 | ||
DIST ReText-5.3.1.tar.gz 159669 SHA256 515b1aaa57615453f8933f997753072a5c4691793da2280e70d1b333b53904c6 SHA512 76c6f78c10129e4845de819fa6db3deff5441a25331fd3dadbdfeb766caa453f21214f82e6625c919cc8be2fcfdfada970cae32837bb8904c3702dda19890628 WHIRLPOOL 5c2db75c2b2f23419bc2803849f6b7a69f3540911c6e53f46a46baffd150a9a0db75d0343361963a53bcc1a6da4534eb72d99068a26c13c1551b6188ab81f67a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python3_{3,4} ) | ||
|
||
PLOCALES="ca cs cy da de es et eu fr hu it ja pl pt pt_BR ru sk sr sr@latin uk zh_TW" | ||
|
||
inherit distutils-r1 l10n | ||
|
||
MY_PN="ReText" | ||
MY_P="${MY_PN}-${PV/_/~}" | ||
|
||
DESCRIPTION="Simple editor for Markdown and reStructuredText" | ||
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki" | ||
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+spell" | ||
|
||
RDEPEND=" | ||
dev-python/docutils[${PYTHON_USEDEP}] | ||
dev-python/markdown[${PYTHON_USEDEP}] | ||
dev-python/markups[${PYTHON_USEDEP}] | ||
dev-python/pygments[${PYTHON_USEDEP}] | ||
dev-python/PyQt5[gui,network,printsupport,webkit,widgets,${PYTHON_USEDEP}] | ||
spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
S="${WORKDIR}"/${MY_P} | ||
|
||
remove_locale() { | ||
find "${ED}" -name "retext_${1}.qm" -delete || die "Failed to remove locale ${1}." | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
l10n_for_each_disabled_locale_do remove_locale | ||
|
||
make_desktop_entry ${PN} "${MY_PN} Editor" ${PN} "Development;Utility;TextEditor" | ||
} |