forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-freebsd/freebsd-mk-defs: Revert "Drop versions with old EAPI"
Revert the removal of old versions that broke depgraph for amd64-fbsd.
- Loading branch information
Showing
3 changed files
with
80 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,3 @@ | ||
DIST freebsd-share-8.2.tar.bz2 3797560 BLAKE2B 411eae0c8da465cbfb61be450bc72218b97499aa8ce36abbafc8408aa85a10a144b48a0b3941d8049326f1afe9c0306c66ce176e8fb456981185c39671100cbb SHA512 b3f964253f80e58cde12f26e48a23aa75c17b9ab2810f91a4bd2d7efbe902af7c73c219f8373a4fc97ee0a35d25627b8815c79c136ef18620acc8bd0ee5bd6c4 | ||
DIST freebsd-share-9.1.tar.bz2 6733003 BLAKE2B 12bff34814fc3e893a95480a3ed1a389f426b6c7c7526c572aaf3bf710258feae78f09390dc29ccf563eb700407ab2f600c251c4a3927556e9d5ca323f37b17f SHA512 9665e3d5253f49a55921012bd21a8688210a1993ba6be4ad17b5ba5619104a50f3199d49a0eb83cf29db5a06c407beb15616bfe71338c680fe34ec47564c4b43 | ||
DIST freebsd-src-11.1.tar.xz 147661560 BLAKE2B a9e6ba9d0e12c8b56ac58575d5f02931edbb6a3545d9dccae78810d2d0470a29b29dd7f724b03b8afafbca23717a71346e4cfbd3530e0f40118a23609c3f414e SHA512 b97707ec7a601ca6bcb682c45f6d94a38484301ac24630d7285eff6f88b027ce6900c93fc62f8ce36e0cf32c91f73a9d1c999db397b7f8782fd74a8551a03aca |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2011 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
inherit bsdmk freebsd | ||
|
||
DESCRIPTION="Makefile definitions used for building and installing libraries and system files" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~sparc-fbsd ~x86-fbsd" | ||
|
||
IUSE="" | ||
|
||
SRC_URI="mirror://gentoo/${SHARE}.tar.bz2" | ||
|
||
RDEPEND="" | ||
DEPEND="" | ||
|
||
RESTRICT="strip" | ||
|
||
S="${WORKDIR}/share/mk" | ||
|
||
src_unpack() { | ||
unpack ${A} | ||
|
||
cd "${S}" | ||
epatch "${FILESDIR}/${PN}-8.0-gentoo.patch" | ||
|
||
[[ ${CHOST} != *-*bsd* || ${CHOST} == *-gnu ]] && \ | ||
epatch "${FILESDIR}/${PN}-8.0-gnu.patch" | ||
} | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
if [[ ${CHOST} != *-freebsd* ]]; then | ||
insinto /usr/share/mk/freebsd | ||
else | ||
insinto /usr/share/mk | ||
fi | ||
doins *.mk *.awk | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=3 | ||
|
||
inherit bsdmk freebsd | ||
|
||
DESCRIPTION="Makefile definitions used for building and installing libraries and system files" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd" | ||
|
||
IUSE="userland_GNU" | ||
|
||
SRC_URI="mirror://gentoo/${SHARE}.tar.bz2" | ||
|
||
RDEPEND="" | ||
DEPEND="" | ||
|
||
RESTRICT="strip" | ||
|
||
S="${WORKDIR}/share/mk" | ||
|
||
src_prepare() { | ||
epatch "${FILESDIR}/${PN}-9.1-gentoo.patch" | ||
epatch "${FILESDIR}/${PN}-add-nossp-cflags.patch" | ||
use userland_GNU && epatch "${FILESDIR}/${PN}-9.1-gnu.patch" | ||
} | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
if [[ ${CHOST} != *-freebsd* ]]; then | ||
insinto /usr/share/mk/freebsd | ||
else | ||
insinto /usr/share/mk | ||
fi | ||
doins *.mk *.awk | ||
} |