Skip to content

Commit

Permalink
gnome-extra/gucharmap: Version bump to 15.1.2
Browse files Browse the repository at this point in the history
Signed-off-by: Guillermo Joandet <[email protected]>
Closes: gentoo#33461
Signed-off-by: Pacho Ramos <[email protected]>
  • Loading branch information
flint2 authored and pacho2 committed Oct 26, 2023
1 parent 99e8817 commit ed2187d
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/gucharmap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gucharmap-15.0.4.tar.bz2 1453197 BLAKE2B 718890e466e19934b012a79deefc2174edba6de59bd9a374dee5e8cf396fd0a06ae8e4db4cfb223d43284d59be87344310e4cb94e1e45ae158e0213e7bfa06f5 SHA512 280fb164f2d850f9b4a8e54c24d0bc461e0abe2e53f34a6f2f0098397c04856091c6f730cfa9451de5b676b569e2a43bcf2a9dfe160f916b00622ec5535c1e94
DIST gucharmap-15.1.1.tar.bz2 1455226 BLAKE2B c7dd7fc41dd938f040829ad4f6c29027441125c8d9c27e7539867230e2f1842039af02d52450cdc3be234a836d5f27cda90b565210c979c896abe1209e0695fa SHA512 e6fd7a29ecec8b0d094396f86a0204bd1e9e09a02c71930f95f43f707ff46db4f92c87b00d2840739f3191f3ebc84dfdde1c879dc26dc1888d1085cb032927b5
DIST gucharmap-15.1.2.tar.bz2 1455600 BLAKE2B 991388c67451df701533d9935021644aa549a373d07dbdca47ee47e76b419533e5ecf16ddfb4603467f7750fe6934fbef37ecd88795ebf11e066a3f1d76e327b SHA512 702276b0fd7804d4210b71e332a34206f27c0da5fefbf164a70881d97d0cbcd3cdb9f8b31e56ee449cb07688bdbbe6fa1d7fa8e7a5fe5c5b879a6ce828450e69
76 changes: 76 additions & 0 deletions gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
PYTHON_COMPAT=( python3_{10..12} )

inherit gnome2-utils meson python-any-r1 vala xdg

DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"

LICENSE="GPL-3+"
SLOT="2.90"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"

UNICODE_VERSION="15.1.0"

IUSE="+introspection gtk-doc vala"
REQUIRED_USE="vala? ( introspection )"

RDEPEND="media-libs/freetype:2
>=dev-libs/glib-2.32:2
>=x11-libs/gtk+-3.22:3[introspection?]
>=dev-libs/libpcre2-10.21:=
=app-i18n/unicode-data-${UNICODE_VERSION}*
>=x11-libs/pango-1.42.4-r2[introspection?]
!gnome-extra/gucharmap:0
"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
app-text/docbook-xml-dtd:4.1.2
dev-libs/glib:2
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
gtk-doc? ( >=dev-util/gtk-doc-1 )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
vala? ( $(vala_depend) )
"

PATCHES=(
"${FILESDIR}"/14.0.1-install-user-help.patch
)

src_prepare() {
default
use vala && vala_setup
xdg_environment_reset
}

src_configure() {
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
$(meson_use gtk-doc docs)
$(meson_use introspection gir)
-Dgtk3=true
-Ducd_path="${EPREFIX}/usr/share/unicode-data"
$(meson_use vala vapi)
)

meson_src_configure
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit ed2187d

Please sign in to comment.