Skip to content

Commit

Permalink
net-misc/ntp: Bump to version 4.2.8_p5
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 13, 2016
1 parent 2db723b commit ed43728
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
2 changes: 2 additions & 0 deletions net-misc/ntp/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -8,3 +8,5 @@ DIST ntp-4.2.8p3-manpages.tar.bz2 46419 SHA256 83f9641e52fd79ac8bd76f7d622145913
DIST ntp-4.2.8p3.tar.gz 7099575 SHA256 818ca4f2ed6ca845b1c5ec43f5e6ad905eaa0fc0aab2d509ed6b962a37fbf38f SHA512 5a628f72e900ac8c8a4754bc9620e6511f68035b3a1e1108d619b1beab307d3f6c9f5dad4f3ca3f4e252d0e7e3bf48900044df2934aa87df1f699316db5e9598 WHIRLPOOL 4d66c9403b0bf8b4a9b297bd13974f88bcdc3f524bede0e633f7ee17b688bdd60dcc4e8a23fa7a4efd82540fab515df0b40c140edbefd1bb51352edd06b08d2d
DIST ntp-4.2.8p4-manpages.tar.bz2 24655 SHA256 fe368d6c30c8c9c3f6e7959b00fc82695e122b29d597090f3725a9a00de92da6 SHA512 80a56b5b736810e4c04e128ce5565fc3834dc0b899b2fdd4173c8dd7f53d353209b648186d0183b9aecd9debec60f2d0b179d229032971876269810bd72096a7 WHIRLPOOL b97331e8e565377bac8fe6cc53cbab0e20a36357f3c142d68505b31104187b117e823ddabbe767e841efbd28b8c0476c460e00cd777619e8f190c7fa2aac0e9e
DIST ntp-4.2.8p4.tar.gz 7104852 SHA256 0d6961572548d2c4af96f58f763e22ac620f5afef717384ddc317a0e365cfdb9 SHA512 e5ad7b44921e49b5546aa804dc56c320a3a0beb32b0e6fde40c900bf5e3af40b354a0cecc869b4605b59b5ab58219b9940789b50d747e0f5b50b4e73513d9f23 WHIRLPOOL 0fdbf4fddf726c52a7533aa45e9947f380ff7edb79abc1852355f0fe387472b28318027a738c85fa021e0b24b0e309a0aa03ef420f5873ce9ef5fa0a155eba6b
DIST ntp-4.2.8p5-manpages.tar.bz2 24626 SHA256 a26de4f83a6d8d6e0aa2d20bb6b8c8f7667993652e15d174c1bac91656c4dbec SHA512 5a5a51afca6fd91240c5fe8cbfa8d29b02e1bc46cb37eaa4032ced3b23caee7f2f80fda9ccdf93454bf33a465face0f3c4afb3c76a33352005f3fdd74de05076 WHIRLPOOL bcdb17da93a2c01c25c2ea36c8144ad1e3373e4d584856a7affea548aa8db048da4f759c00e06a617f083107771cf2b552eba76a806c1bbda1d5251fccc15570
DIST ntp-4.2.8p5.tar.gz 7138233 SHA256 ca28baf4f6bb6fabdc1b62fd1dcec412be2e621192b40466a469a2496164f696 SHA512 8df3e51027f6bfc5e77b81317b67e75263cb429dc532d21bb5924852f77ea39314a06b94944804991185f93155063cee7c1f28024698ec893c353a4d5561750e WHIRLPOOL bcd60d6ee8b8fd19095fe335cdc05a8d58973ca467c5c603860deaefa43cb25597ded1acf7de57598a2e9a521b7e0fa6d2e544cb1aedd16aad08f44854b9f7fc
133 changes: 133 additions & 0 deletions net-misc/ntp/ntp-4.2.8_p5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,133 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils toolchain-funcs flag-o-matic user systemd

MY_P=${P/_p/p}
DESCRIPTION="Network Time Protocol suite/programs"
HOMEPAGE="http://www.ntp.org/"
SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar.gz
https://dev.gentoo.org/~polynomial-c/${MY_P}-manpages.tar.bz2"

LICENSE="HPND BSD ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~m68k-mint"
IUSE="caps debug ipv6 libressl openntpd parse-clocks readline samba selinux snmp ssl +threads vim-syntax zeroconf"

CDEPEND="readline? ( >=sys-libs/readline-4.1:0= )
>=dev-libs/libevent-2.0.9[threads?]
kernel_linux? ( caps? ( sys-libs/libcap ) )
zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
!openntpd? ( !net-misc/openntpd )
snmp? ( net-analyzer/net-snmp )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
)
parse-clocks? ( net-misc/pps-tools )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-ntp )
vim-syntax? ( app-vim/ntp-syntax )"
PDEPEND="openntpd? ( net-misc/openntpd )"

S=${WORKDIR}/${MY_P}

pkg_setup() {
enewgroup ntp 123
enewuser ntp 123 -1 /dev/null ntp
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-4.2.8-ipc-caps.patch #533966
epatch "${FILESDIR}"/${PN}-4.2.8-sntp-test-pthreads.patch #563922
epatch "${FILESDIR}"/${PN}-4.2.8-ntpd-test-signd.patch
append-cppflags -D_GNU_SOURCE #264109
# Make sure every build uses the same install layout. #539092
find sntp/loc/ -type f '!' -name legacy -delete || die
# Disable pointless checks.
touch .checkChangeLog .gcc-warning FRC.html html/.datecheck
}

src_configure() {
# avoid libmd5/libelf
export ac_cv_search_MD5Init=no ac_cv_header_md5_h=no
export ac_cv_lib_elf_nlist=no
# blah, no real configure options #176333
export ac_cv_header_dns_sd_h=$(usex zeroconf)
export ac_cv_lib_dns_sd_DNSServiceRegister=${ac_cv_header_dns_sd_h}
# Increase the default memlimit from 32MiB to 128MiB. #533232
econf \
--with-lineeditlibs=readline,edit,editline \
--with-yielding-select \
--disable-local-libevent \
--docdir='$(datarootdir)'/doc/${PF} \
--htmldir='$(docdir)/html' \
--with-memlock=256 \
$(use_enable caps linuxcaps) \
$(use_enable parse-clocks) \
$(use_enable ipv6) \
$(use_enable debug debugging) \
$(use_with readline lineeditlibs readline) \
$(use_enable samba ntp-signd) \
$(use_with snmp ntpsnmpd) \
$(use_with ssl crypto) \
$(use_enable threads thread-support)
}

src_install() {
default
# move ntpd/ntpdate to sbin #66671
dodir /usr/sbin
mv "${ED}"/usr/bin/{ntpd,ntpdate} "${ED}"/usr/sbin/ || die "move to sbin"

dodoc INSTALL WHERE-TO-START
doman "${WORKDIR}"/man/*.[58]

insinto /etc
doins "${FILESDIR}"/ntp.conf
use ipv6 || sed -i '/^restrict .*::1/d' "${ED}"/etc/ntp.conf #524726
newinitd "${FILESDIR}"/ntpd.rc-r1 ntpd
newconfd "${FILESDIR}"/ntpd.confd ntpd
newinitd "${FILESDIR}"/ntp-client.rc ntp-client
newconfd "${FILESDIR}"/ntp-client.confd ntp-client
newinitd "${FILESDIR}"/sntp.rc sntp
newconfd "${FILESDIR}"/sntp.confd sntp
if ! use caps ; then
sed -i "s|-u ntp:ntp||" "${ED}"/etc/conf.d/ntpd || die
fi
sed -i "s:/usr/bin:/usr/sbin:" "${ED}"/etc/init.d/ntpd || die

keepdir /var/lib/ntp
use prefix || fowners ntp:ntp /var/lib/ntp

if use openntpd ; then
cd "${ED}"
rm usr/sbin/ntpd || die
rm -r var/lib
rm etc/{conf,init}.d/ntpd
rm usr/share/man/*/ntpd.8 || die
else
systemd_newunit "${FILESDIR}"/ntpd.service-r2 ntpd.service
use caps && sed -i '/ExecStart/ s|$| -u ntp:ntp|' "${ED}"/usr/lib/systemd/system/ntpd.service
systemd_enable_ntpunit 60-ntpd ntpd.service
fi

systemd_newunit "${FILESDIR}"/ntpdate.service-r1 ntpdate.service
systemd_install_serviced "${FILESDIR}"/ntpdate.service.conf
systemd_newunit "${FILESDIR}"/sntp.service-r2 sntp.service
systemd_install_serviced "${FILESDIR}"/sntp.service.conf
}

pkg_postinst() {
if grep -qs '^[^#].*notrust' "${EROOT}"/etc/ntp.conf ; then
eerror "The notrust option was found in your /etc/ntp.conf!"
ewarn "If your ntpd starts sending out weird responses,"
ewarn "then make sure you have keys properly setup and see"
ewarn "https://bugs.gentoo.org/41827"
fi
}

0 comments on commit ed43728

Please sign in to comment.