Skip to content

Commit

Permalink
app-admin/sysstat: Versions 11.6.5 12.0.1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.44, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Aug 7, 2018
1 parent a6ebaf7 commit ed9bc6a
Show file tree
Hide file tree
Showing 3 changed files with 176 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-admin/sysstat/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,7 @@
DIST sysstat-11.4.0.tar.xz 343968 BLAKE2B e34da8cf0216f66fad3ade0ed40e8ec3b7641f7568ebcce5bc3122f888c90885ece346bf7f4f8e71e92435257ee5c6c0e5a89913c0e22a0ad28fa1018a73ea71 SHA512 4a5c81d75fdbc8dcaf80685f302688c39bd7143554e5a06cb324532ddb5180caac19b261182d5320f40b317bdb1e81664887acc7cedfeb5a95dc6ad37a898604
DIST sysstat-11.6.3.tar.xz 527828 BLAKE2B 4221252589652d949541d8ec8d7057abe90cafaae7b2222538d4fcb95aaa45f3da542539eb0742a910456c8ee134203207fc5e9485b0948a6c581f33eb949c2c SHA512 37a770b4ff26abdb94c8d97fa49b094702e9f5fb12549fd012b9767c7f42ede50ce209085c7ad3b7cd2e208ba1e5bfe9425893f7bb0bbc517aed688300bf9712
DIST sysstat-11.6.4.tar.xz 528028 BLAKE2B 931a172ce399133a0827f7dc7090719e778e7c89a1383adf93a99c386cd11343de26649355dd3a382deceeffe6c2f1890d3424aae6ae441aaa4a47f046b520f7 SHA512 36affc6749d0eef5760e542dde060c257eea323196f9b83b52cc931825dfa796b48cad37060b9ca20d58fb3909c07b8bd67bc8d09c9c6285c08c4e2e9ca1d308
DIST sysstat-11.6.5.tar.xz 527676 BLAKE2B 8473000924514bd089de431c3aa4e042559cac71248555eb97af3a5127d0f4f6c9c13c58ad1cf9254265d2c1c4b68a17b328f883ba80a2bd1a85c5ca7909fe72 SHA512 5e302ad1cd2050c6c391df902babf10a8a37c5458ecccfee173a4f5bce9b0dd7ba0b364e50affee3b38b91ed828e7461cd6f84e249b18d380ba55b655fc0cbe0
DIST sysstat-11.7.3.tar.xz 543556 BLAKE2B f6042021a7c5047727ddbcd38cf6e9f88ca44adaf9f8a9e56cf84c9d9b4d61bef7e07ef910c54fdcc0342c8f9b28e9b114778f57f3ed70d8b950263086426387 SHA512 c752ebba4d25a30147e68d0cb44d93020bb9b44823812c99550f6b34b42fc6f015c28ef0e6609a1e33ae6e4de566ae2d0e8a4711e412a4298baf5721dd15d27f
DIST sysstat-11.7.4.tar.xz 545176 BLAKE2B 08dec13040fe1df87902dfc67bda0ae7281768a4f426906b94d925f302892857091f279d976020924de665a41c4d73f3b64b48394436639804aab0b28bffce94 SHA512 4dcb05799e82410f2a13b44c2de1f6c7d31f20410e8a9528ac365a059591c04f918ad51c42b73fd06489bbed48a181b290897a91e9837b685cfc51c006aa8a05
DIST sysstat-12.0.1.tar.xz 602484 BLAKE2B 68f6f54a931f1b502ab065f25cd49c9d631d40689b380b5d535c540416a3c05233dbf151b7d8bec7061fbc8eb6fb61860ed6f5ef0d611314191a2c36601437ca SHA512 d8940dc71592c041f59b2b0bcda7ae2748f0527832e6da7b4722dc91abb0139f1b5c528d50c97b4df0bcb5607b844bed3651183acea738b02f3a8e88809740f9
89 changes: 89 additions & 0 deletions app-admin/sysstat/sysstat-11.6.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="${HOMEPAGE}${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm_sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm_sensors? ( sys-apps/lm_sensors )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-10.0.4-flags.patch
"${FILESDIR}"/${PN}-11.0.4-cron.patch
)

SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/$(get_libdir)/sa \
conf_dir=/etc \
rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
$(use_enable nls) \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_compile() {
emake LFLAGS="${LDFLAGS}"
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm -f "${D}"usr/share/doc/${PF}/COPYING
}
85 changes: 85 additions & 0 deletions app-admin/sysstat/sysstat-12.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="${HOMEPAGE}${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm_sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm_sensors? ( sys-apps/lm_sensors )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-11.0.4-cron.patch
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)

SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/$(get_libdir)/sa \
conf_dir=/etc \
rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
$(use_enable nls) \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm -f "${D}"usr/share/doc/${PF}/COPYING
}

0 comments on commit ed9bc6a

Please sign in to comment.