Skip to content

Commit

Permalink
dev-ruby/rspec-support: add 3.11.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Feb 11, 2022
1 parent 7fa27ee commit edb0ecc
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rspec-support/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST rspec-support-3.10.2-git.tgz 74812 BLAKE2B e6c7e768d0df05fa5e77055efcc69699192928a35029264300faccf500b1ce7367e74e9c2ae0f7f8f0a5e755692ac83b982d0a3dab3da3ab697ad2c5766aa30d SHA512 bd1fb5d737dfdbb7399d766854f0b173dad89675bac580cf65c5d42ab6cd04ad1773e7cfa875dfa4c6fac14f4ccbd6b48813bae5de26c931c804962d29b014be
DIST rspec-support-3.10.3-git.tgz 75447 BLAKE2B d3eae3b148ef56d6a8668ad4c92ce52ea066c82442448446cbdc6d37137c6fa32bf54e5f579d4a39525305fdd795feee792dac29234c568ab85d59d684af4b84 SHA512 21d7f3076e11467ef6c5b7ce23d5a8635320ca21f61f0d640e45c4e7855995a672fe400fc11f7dbea37097f6eefe09f24d3b177c86e75b2454a97c898f9a1cdf
DIST rspec-support-3.11.0-git.tgz 75644 BLAKE2B 349df9b326e98fd3564ae22c8659c95205d5e623f0e67721cdb3dd658bdbee5ec574f4286d9548984567079178997c6e9b419211c7c3da601dd02ad3aa0d448f SHA512 38bd7c132b6dea3036c8c18e6c535c2dfb5faa0601fb13eb406c8bb279e42e460cecb823527b04a22966f0e965eda6b539e48cbac20c663ae3a17c01f4fbd0e0
DIST rspec-support-3.9.4-git.tgz 72490 BLAKE2B 03c3ba8316a2c6a79faf68db87adf193b684b82119dd9c5b67f2954f3ce72cf03e3e16898e2f5d57d76aef37bb8fb08ab8dacf8aaef6d1445a8257e2be14afe5 SHA512 95be2e03c37117d6bc132ce466779a8ac3c4fedadfb2a6dabb1fa11601aae908e341c87436dd526bbc8b02040b23200c95bd113d0475405afdb4acd099c67403
51 changes: 51 additions & 0 deletions dev-ruby/rspec-support/rspec-support-3.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26 ruby27 ruby30"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="https://github.com/rspec/rspec-support"
SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"

LICENSE="MIT"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_bdepend "test? ( >=dev-ruby/rspec-3.9.0:3 >=dev-ruby/thread_order-1.1.0 )"

all_ruby_prepare() {
sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die

# Remove spec that, by following symlinks, tries to scan pretty much
# the whole filesystem.
rm spec/rspec/support/caller_filter_spec.rb || die

# Avoid spec that requires a dependency on git
sed -i -e '/library wide checks/,/]/ s:^:#:' spec/rspec/support_spec.rb || die

# Avoid a spec requiring a specific locale
sed -i -e '/copes with encoded strings/ s/RSpec::Support::OS.windows?/true/' spec/rspec/support/differ_spec.rb || die

# Avoid a brittle spec depending on ruby implementation details
# should be fixed upstream in next version
#sed -i -e '/returns a hash containing nodes for each line number/askip "ruby26"' spec/rspec/support/source_spec.rb || die
}

each_ruby_prepare() {
# Use the ruby version being tested
sed -i -e '/shell_out/ s:ruby:'${RUBY}':' spec/rspec/support/spec/shell_out_spec.rb || die
}

each_ruby_test() {
RUBYLIB=lib ${RUBY} -S rspec spec || die
}

0 comments on commit edb0ecc

Please sign in to comment.