Skip to content

Commit

Permalink
app-backup/snapper: remove ext4, force btrfs
Browse files Browse the repository at this point in the history
Snapper's ext4 code does not work anymore.
So we need to compile with --disable-ext4 by default.

Also snapper does not seem to work without btrfs enabled, so we need to
enable it by default.

Closes: gentoo#7473
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
jubalh authored and mgorny committed Mar 25, 2018
1 parent c99899d commit edcb856
Showing 1 changed file with 8 additions and 9 deletions.
17 changes: 8 additions & 9 deletions app-backup/snapper/snapper-0.5.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,29 +1,28 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit systemd

DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
HOMEPAGE="http://snapper.io/"
SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+btrfs ext4 lvm pam xattr"
IUSE="lvm pam xattr"

RDEPEND="dev-libs/boost:=[threads]
dev-libs/libxml2
dev-libs/icu:=
sys-apps/acl
sys-apps/dbus
sys-apps/util-linux
>=sys-fs/btrfs-progs-3.17.1
sys-libs/zlib
virtual/libintl
btrfs? ( >=sys-fs/btrfs-progs-3.17.1 )
ext4? ( sys-fs/e2fsprogs )
lvm? ( sys-fs/lvm2 )
pam? ( sys-libs/pam )
xattr? ( sys-apps/attr )"
Expand All @@ -32,8 +31,6 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"

REQUIRED_USE="|| ( btrfs ext4 lvm )"

PATCHES=(
"${FILESDIR}"/cron-confd.patch
)
Expand All @@ -47,13 +44,15 @@ src_prepare() {
}

src_configure() {
# ext4 code does not work anymore
# snapper does not build without btrfs
local myeconfargs=(
--with-conf="/etc/conf.d"
--docdir="/usr/share/doc/${PF}"
--disable-zypp
--enable-rollback
$(use_enable btrfs)
$(use_enable ext4)
--disable-ext4
--enable-btrfs
$(use_enable lvm)
$(use_enable pam)
$(use_enable xattr xattrs)
Expand Down

0 comments on commit edcb856

Please sign in to comment.