Skip to content

Commit

Permalink
kde-apps/ktuberling: Drop unused deps
Browse files Browse the repository at this point in the history
Gentoo-bug: 581588

Package-Manager: portage-2.2.27

Signed-off-by: Johannes Huber <[email protected]>
  • Loading branch information
a17r authored and johu committed May 6, 2016
1 parent c0ccc55 commit ee16002
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 3 deletions.
53 changes: 53 additions & 0 deletions kde-apps/ktuberling/files/ktuberling-15.12.3-deps.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
commit ed566185fe698c71714009602c4dfbe4a91e0313
Author: Andreas Sturmlechner <[email protected]>
Date: Thu May 5 00:32:34 2016 +0200

Fix dependencies (drop unused, add missing)

REVIEW: 127832

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2df6ca6..884a4b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,23 +6,18 @@ set (QT_MIN_VERSION "5.3.0")
find_package(ECM 1.7.0 REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})

-find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets Qml Quick QuickWidgets Svg Test)
-find_package(KF5 REQUIRED COMPONENTS
- CoreAddons
- Config
- ItemModels
- WidgetsAddons
- WindowSystem
+find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS PrintSupport Svg Widgets Xml)
+find_package(KF5 REQUIRED COMPONENTS
+ Completion
Config
+ ConfigWidgets
+ CoreAddons
DBusAddons
I18n
- ConfigWidgets
- TextWidgets
+ KDELibs4Support #TODO eventually remove kdelibs4support
+ WidgetsAddons
XmlGui
- KIO
- NotifyConfig
- NewStuff
- KDELibs4Support) #TODO eventually remove kdelibs4support
+)

find_package(KF5KDEGames 4.9.0 REQUIRED)
find_package(Phonon4Qt5 CONFIG REQUIRED)
@@ -58,7 +53,7 @@ file(GLOB ICONS_SRCS "${CMAKE_CURRENT_SOURCE_DIR}/*-apps-ktuberling.png")
ecm_add_app_icon(ktuberling_SRCS ICONS ${ICONS_SRCS})
add_executable(ktuberling ${ktuberling_SRCS})

-target_link_libraries(ktuberling KF5::KIOCore KF5KDEGames Phonon::phonon4qt5 Qt5::Svg Phonon::phonon4qt5 KF5::DBusAddons KF5::XmlGui KF5::Completion Qt5::PrintSupport KF5::KDELibs4Support)
+target_link_libraries(ktuberling KF5KDEGames Phonon::phonon4qt5 Qt5::Svg KF5::DBusAddons KF5::XmlGui KF5::Completion Qt5::PrintSupport KF5::KDELibs4Support)

install(TARGETS ktuberling ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )

6 changes: 3 additions & 3 deletions kde-apps/ktuberling/ktuberling-15.12.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,7 @@

EAPI=6

KDE_HANDBOOK="true"
KDE_PUNT_BOGUS_DEPS="true"
KDE_HANDBOOK="forceoptional"
KDE_SELINUX_MODULE="games"
inherit kde5

Expand Down Expand Up @@ -35,5 +34,6 @@ DEPEND="
$(add_qt_dep qtxml)
media-libs/phonon[qt5]
"

RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}-deps.patch" )

0 comments on commit ee16002

Please sign in to comment.