Skip to content

Commit

Permalink
dev-ruby/actionpack: add 7.0.7.2
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Aug 23, 2023
1 parent b25099a commit ee22904
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/actionpack/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST rails-6.1.7.4.tgz 11038583 BLAKE2B 737044b6f92f2555fd9374e0b0fef7e26e53e2ac2103f1e3d89124929416aeda1295adfa7493471472c6ff0fbb057dea0bd9c184bbb45ae572185b98c399177f SHA512 caa7e2a79f747befb5f6f17adec1cc43530dbb35741775b2ebdcf59476efecd277dad025073a4b519a35754367cca04290c24bb8d8ae4235fda696ead531a94f
DIST rails-7.0.5.1.tgz 11077848 BLAKE2B 17dc2527b762d242c1cc141b5480c0917c8eafb53c55d3034d5af272e9be5760f6c3e16ce1a60041f11af4f99da23e79ff46e9f9fe88412932f2524bf057c478 SHA512 5053ed666cede0bfeb7a534f248538406a1bf5afe0d5ee9e285b4eeb3158566fdd665c7a20012833e6927e7dbb3d881361a5d7f8ce7e326f8e3faf5d571da3e7
DIST rails-7.0.6.tgz 11090672 BLAKE2B 87d3c1d37f0af4c6a9590d9e38cf1674c59b01b1e15d9883e4d303935b13c48cf9a53d9b3db63490a515b035ba500c6db9b938c329ee82f3adf9eb5897a69fe7 SHA512 93d91d25117e01460d3bd9bdd21743d19f377487a4cd2d0cd22f4d9deba524451033c83f52515270ff823b6c26306fe30be8c360bb527c59a789c04dd5fc1dac
DIST rails-7.0.7.2.tgz 11085454 BLAKE2B 05574b6df7e28e409949fb311110fd7137d61c31072b394f950a180135201132f3cf9c5cca8f76c661827d7a5e807bfc4b0c97a449b8941115cbe3a0f2f84f62 SHA512 41fad11bd272ea21f7d15d855da04230f0801d9926f6ce3300754f1b2b9d691f18e55855b1a71e44faaf483b397b02ac11c75eb415b7c8976868bc9aefe5b005
DIST rails-7.0.7.tgz 11071730 BLAKE2B 215642609be86bd9977dc2cdb09a76c64e99260359d0a60aa411a5df572d7699a5f9959ea8aa0ff116ad75110db060436abcfb17da689b1a6aa819fd56373279 SHA512 75f952dfe4d9abc1473dfb017e42daec6358a45efad14a3b39a1b2dc5fec566757c2225fe920a4e872e896966cfb1d4b6e1c40c93d2043aec3bf5bd25ff7c956
70 changes: 70 additions & 0 deletions dev-ruby/actionpack/actionpack-7.0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_RUBY="ruby30 ruby31 ruby32"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Eases web-request routing, handling, and response"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
~dev-ruby/activesupport-${PV}
~dev-ruby/actionview-${PV}
dev-ruby/rack:2.2
>=dev-ruby/rack-test-0.6.3:*
>=dev-ruby/rails-html-sanitizer-1.2.0:1
dev-ruby/rails-dom-testing:2
"

ruby_add_bdepend "
test? (
dev-ruby/mocha:0.14
dev-ruby/bundler
>=dev-ruby/capybara-3.26
~dev-ruby/activemodel-${PV}
~dev-ruby/railties-${PV}
>=dev-ruby/rack-cache-1.2:1.2
dev-ruby/selenium-webdriver:4
www-servers/puma
<dev-ruby/minitest-5.16:*
)"

all_ruby_prepare() {
eapply "${FILESDIR}/actionpack-7.0.4-rack-test-2.patch"

# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
rm ../Gemfile.lock || die

sed -i -e '3igem "rack", "<3"; gem "minitest", "<5.16"' test/abstract_unit.rb || die

# Use different timezone notation, this changed at some point due to an external dependency changing.
sed -e 's/-0000/GMT/' \
-i test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die

# Avoid tests that fail with a fixed cgi.rb version
sed -e '/test_session_store_with_all_domains/askip "Fails with fixed cgi.rb"' \
-i test/dispatch/session/cookie_store_test.rb || die
}

0 comments on commit ee22904

Please sign in to comment.