Skip to content

Commit

Permalink
dev-games/physfs: Bump to version 3.0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Mar 21, 2019
1 parent 0a41a80 commit ee56026
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-games/physfs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST physfs-2.0.3.tar.bz2 560628 BLAKE2B 8e3e8497463886678aaa671269133513f08aab1e49a6397f61cd44a5139030326ae0889e795401a967b0641f680f353dfaa39d7102502c2b8e0680c0a5d158b5 SHA512 47eff0c81b8dc3bb526766b0a8ad2437d2951867880116d6e6e8f2ec1490e263541fb741867fed6517cc3fa8a9c5651b36e3e02a499f19cfdc5c7261c9707e80
DIST physfs-3.0.1.tar.bz2 194638 BLAKE2B a95e599ad5c8c5aafcd9b6569c8b7762bdd0fcdbf9502f8fda61f5068b25c8cf651ce6127a1f139b20baa93bd9ab001d2527aedc0180c3b60246410ab0d35acb SHA512 ddf3b075ccb506da5e9a1ce96001be402752b9b777c2e816a85d48aff3626ff0886ea43eb07bd300fe3a9f59b9a002f54d822c51d483a4ee94b38378534c1879
DIST physfs-3.0.2.tar.bz2 194888 BLAKE2B 67b6b04e3822c2528a31a2c60345238cb5f25ad031e32a6c3416b91bad6347af9f02dcfb8dc29a71c2bfc2b7cec7f0749ffbbd0dcadbc35703576ad895f568d9 SHA512 4024b6c3348e0b6fc1036aac330192112dfe17de3e3d14773be9f06e9a062df5a1006869f21162b4e0b584989f463788a35e64186b1913225c073fea62754472
56 changes: 56 additions & 0 deletions dev-games/physfs/physfs-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit cmake-multilib

DESCRIPTION="Abstraction layer for filesystem and archive access"
HOMEPAGE="https://icculus.org/physfs/"

if [[ ${PV} == *9999* ]]; then
EHG_REPO_URI="https://hg.icculus.org/icculus/physfs"
inherit mercurial
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
SRC_URI="https://icculus.org/physfs/downloads/${P}.tar.bz2"
fi

LICENSE="ZLIB"
SLOT="0"
IUSE="7zip doc grp hog iso mvl qpak slb static-libs vdf wad +zip"

BDEPEND="doc? ( app-doc/doxygen )"

DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )

multilib_src_configure() {
local mycmakeargs=(
-DPHYSFS_BUILD_SHARED=ON
-DPHYSFS_BUILD_TEST=OFF
-DPHYSFS_BUILD_STATIC="$(usex static-libs)"
-DPHYSFS_ARCHIVE_7Z="$(usex 7zip)"
-DPHYSFS_ARCHIVE_GRP="$(usex grp)"
-DPHYSFS_ARCHIVE_HOG="$(usex hog)"
-DPHYSFS_ARCHIVE_ISO9660="$(usex iso)"
-DPHYSFS_ARCHIVE_MVL="$(usex mvl)"
-DPHYSFS_ARCHIVE_SLB="$(usex slb)"
-DPHYSFS_ARCHIVE_VDF="$(usex vdf)"
-DPHYSFS_ARCHIVE_WAD="$(usex wad)"
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
cmake-utils_src_configure
}

multilib_src_compile() {
cmake-utils_src_compile
multilib_is_native_abi && use doc && cmake-utils_src_compile docs
}

multilib_src_install_all() {
einstalldocs
if use doc ; then
docinto html
dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
fi
}

0 comments on commit ee56026

Please sign in to comment.