Skip to content

Commit

Permalink
dev-php/phar-io-manifest: new package
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3

Signed-off-by: Michael Orlitzky <[email protected]>
  • Loading branch information
kitsunenokenja authored and orlitzky committed Feb 14, 2018
1 parent edf385b commit ee86c6c
Show file tree
Hide file tree
Showing 4 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/phar-io-manifest/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST phar-io-manifest-1.0.1.tar.gz 21403 BLAKE2B 0f18d94d127ec54914cb60756fd3e75c2d13ec593b7101735e385e4515abf4da0f03ef94d0bbbfaee02f348309525504f5e99e150a68b0d0fcd2129ccade4541 SHA512 3e4dd7ddd6de0a9f70595d0d8a6721782d2584526d3d4649cf0338ab36f106798daf4b7dcbf5bd972893a1569b622e4217212e5812b14e4bf3f698504f4d2228
62 changes: 62 additions & 0 deletions dev-php/phar-io-manifest/files/autoload.php
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
<?php
/* Autoloader for dev-php/phar-io-manifest */
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';

\Fedora\Autoloader\Autoload::addClassMap(
[
'phario\\manifest\\manifestdocumentmapper' => '/ManifestDocumentMapper.php',
'phario\\manifest\\manifestloader' => '/ManifestLoader.php',
'phario\\manifest\\manifestserializer' => '/ManifestSerializer.php',
'phario\\manifest\\exception' => '/exceptions/Exception.php',
'phario\\manifest\\invalidapplicationnameexception' => '/exceptions/InvalidApplicationNameException.php',
'phario\\manifest\\invalidemailexception' => '/exceptions/InvalidEmailException.php',
'phario\\manifest\\invalidurlexception' => '/exceptions/InvalidUrlException.php',
'phario\\manifest\\manifestdocumentexception' => '/exceptions/ManifestDocumentException.php',
'phario\\manifest\\manifestdocumentmapperexception' => '/exceptions/ManifestDocumentMapperException.php',
'phario\\manifest\\manifestelementexception' => '/exceptions/ManifestElementException.php',
'phario\\manifest\\manifestloaderexception' => '/exceptions/ManifestLoaderException.php',
'phario\\manifest\\application' => '/values/Application.php',
'phario\\manifest\\applicationname' => '/values/ApplicationName.php',
'phario\\manifest\\author' => '/values/Author.php',
'phario\\manifest\\authorcollection' => '/values/AuthorCollection.php',
'phario\\manifest\\authorcollectioniterator' => '/values/AuthorCollectionIterator.php',
'phario\\manifest\\bundledcomponent' => '/values/BundledComponent.php',
'phario\\manifest\\bundledcomponentcollection' => '/values/BundledComponentCollection.php',
'phario\\manifest\\bundledcomponentcollectioniterator' => '/values/BundledComponentCollectionIterator.php',
'phario\\manifest\\copyrightinformation' => '/values/CopyrightInformation.php',
'phario\\manifest\\email' => '/values/Email.php',
'phario\\manifest\\extension' => '/values/Extension.php',
'phario\\manifest\\library' => '/values/Library.php',
'phario\\manifest\\license' => '/values/License.php',
'phario\\manifest\\manifest' => '/values/Manifest.php',
'phario\\manifest\\phpextensionrequirement' => '/values/PhpExtensionRequirement.php',
'phario\\manifest\\phpversionrequirement' => '/values/PhpVersionRequirement.php',
'phario\\manifest\\requirement' => '/values/Requirement.php',
'phario\\manifest\\requirementcollection' => '/values/RequirementCollection.php',
'phario\\manifest\\requirementcollectioniterator' => '/values/RequirementCollectionIterator.php',
'phario\\manifest\\type' => '/values/Type.php',
'phario\\manifest\\url' => '/values/Url.php',
'phario\\manifest\\authorelement' => '/xml/AuthorElement.php',
'phario\\manifest\\authorelementcollection' => '/xml/AuthorElementCollection.php',
'phario\\manifest\\bundleselement' => '/xml/BundlesElement.php',
'phario\\manifest\\componentelement' => '/xml/ComponentElement.php',
'phario\\manifest\\componentelementcollection' => '/xml/ComponentElementCollection.php',
'phario\\manifest\\containselement' => '/xml/ContainsElement.php',
'phario\\manifest\\copyrightelement' => '/xml/CopyrightElement.php',
'phario\\manifest\\elementcollection' => '/xml/ElementCollection.php',
'phario\\manifest\\extelement' => '/xml/ExtElement.php',
'phario\\manifest\\extelementcollection' => '/xml/ExtElementCollection.php',
'phario\\manifest\\extensionelement' => '/xml/ExtensionElement.php',
'phario\\manifest\\licenseelement' => '/xml/LicenseElement.php',
'phario\\manifest\\manifestdocument' => '/xml/ManifestDocument.php',
'phario\\manifest\\manifestdocumentloadingexception' => '/xml/ManifestDocumentLoadingException.php',
'phario\\manifest\\manifestelement' => '/xml/ManifestElement.php',
'phario\\manifest\\phpelement' => '/xml/PhpElement.php',
'phario\\manifest\\requireselement' => '/xml/RequiresElement.php',
],
__DIR__
);

\Fedora\Autoloader\Dependencies::required([
'/usr/share/php/PharIo/Version/autoload.php'
]);
11 changes: 11 additions & 0 deletions dev-php/phar-io-manifest/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>PHP</name>
</maintainer>
<upstream>
<remote-id type="github">phar-io/manifest</remote-id>
</upstream>
</pkgmetadata>
28 changes: 28 additions & 0 deletions dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PN="manifest"

DESCRIPTION="Component for reading phar.io manifest information from a PHP Archive (PHAR)"
HOMEPAGE="https://github.com/phar-io/manifest"
SRC_URI="https://github.com/phar-io/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""

S="${WORKDIR}/${MY_PN}-${PV}"

RDEPEND="dev-php/fedora-autoloader
>=dev-php/phar-io-version-1.0.1
>=dev-lang/php-5.6[phar]"

src_install() {
insinto /usr/share/php/PharIo/Manifest
doins -r src/*
doins "${FILESDIR}/autoload.php"
dodoc README.md
}

0 comments on commit ee86c6c

Please sign in to comment.