Skip to content

Commit

Permalink
net-proxy/squid: Version bump (v4.6)
Browse files Browse the repository at this point in the history
Signed-off-by: Mikle Kolyada <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
Zlogene committed Mar 4, 2019
1 parent 844671a commit ee8980c
Show file tree
Hide file tree
Showing 5 changed files with 498 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-proxy/squid/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST squid-3.5.27.tar.xz 2303468 BLAKE2B 448dbb703469bdd38a0e88da8e473510e9652fc7c7ae2e48bf687a4c2e1698f3baa92c212631fd3734ee51bead89980d31af58d64654418a7c4c4a16e1be751e SHA512 4172a053c3b7ffe7a12dfb3febac96942d0fbbe7e98e3f797f22cd75b0a3a89cbbfe7260b5daad099e79d5e9303bb5dfbfee7499cb30a90590aa1bd242ff4817
DIST squid-3.5.28.tar.xz 2304680 BLAKE2B 9b41a191210ea441ebd2847e9dc2cfacf3ba9fa8ceb81513b4cb449b13f7e81d28e3f3c9c46003db6d3d8a936fbd2275e42e18c23bd9d7667b9bd6890a1627a8 SHA512 da8367d364725c7fd6330e7588b0ff70d32978a17ca0bc5fe58fa6d12c9d2adb42ade0a492c835761bc7fd67c1a55300b4b7402ad939cf2a2aa5104233bbb74b
DIST squid-4.6.tar.xz 2439792 BLAKE2B 1344acfd4ba135d5ec6881612614f735c6e4791f9b15dcc2f572b93e7f7c9e39585aa0b30aef5b09e40a9599e7fe7d3a118f878adac8f272b014ac3d65a83fae SHA512 dbe2b02b83d53d67459e22a19e71cbf99b66d74a2ddc4bc69310f03a0a6092e5840766ad699fc43893516e97ef89799ef2147dd40f76b0bd688c1e271fd20d06
79 changes: 79 additions & 0 deletions net-proxy/squid/files/squid-4.3-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
--- a/configure.ac 2018-10-14 17:22:35.000000000 +0300
+++ b/configure.ac 2018-10-17 21:27:24.806986467 +0300
@@ -32,9 +32,9 @@ PRESET_CXXFLAGS="$CXXFLAGS"
PRESET_LDFLAGS="$LDFLAGS"

dnl Set default LDFLAGS
-if test "x$LDFLAGS" = "x" ; then
- LDFLAGS="-g"
-fi
+dnl if test "x$LDFLAGS" = "x" ; then
+dnl LDFLAGS="-g"
+dnl fi

# Check for GNU cc
AC_PROG_CC
--- a/src/cf.data.pre 2018-10-14 08:25:34.000000000 +0300
+++ b/src/cf.data.pre 2018-10-17 21:27:24.809986705 +0300
@@ -1520,6 +1520,7 @@ acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
+acl Safe_ports port 901 # SWAT
acl CONNECT method CONNECT
NOCOMMENT_END
DOC_END
@@ -6819,11 +6820,11 @@ COMMENT_END

NAME: cache_mgr
TYPE: string
-DEFAULT: webmaster
+DEFAULT: root
LOC: Config.adminEmail
DOC_START
Email-address of local cache manager who will receive
- mail if the cache dies. The default is "webmaster".
+ mail if the cache dies. The default is "root".
DOC_END

NAME: mail_from
--- a/src/debug.cc 2018-10-14 08:25:34.000000000 +0300
+++ b/src/debug.cc 2018-10-17 21:27:24.807986546 +0300
@@ -490,7 +490,7 @@ _db_init(const char *logfile, const char
#if HAVE_SYSLOG && defined(LOG_LOCAL4)

if (Debug::log_syslog)
- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, syslog_facility);
+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, syslog_facility);

#endif /* HAVE_SYSLOG */

--- a/src/main.cc 2018-10-14 08:25:34.000000000 +0300
+++ b/src/main.cc 2018-10-17 21:28:28.632044541 +0300
@@ -1912,7 +1912,7 @@ watch_child(const CommandLine &masterCom

enter_suid();

- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);

if (!opt_foreground)
GoIntoBackground();
@@ -2012,7 +2012,7 @@ watch_child(const CommandLine &masterCom

if ((pid = fork()) == 0) {
/* child */
- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
(void)execvp(masterCommand.arg0(), kidCommand.argv());
int xerrno = errno;
syslog(LOG_ALERT, "execvp failed: %s", xstrerr(xerrno));
@@ -2024,7 +2024,7 @@ watch_child(const CommandLine &masterCom
}

/* parent */
- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);

// If Squid received a signal while checking for dying kids (below) or
// starting new kids (above), then do a fast check for a new dying kid
19 changes: 19 additions & 0 deletions net-proxy/squid/files/squid.confd-r2
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Config file for /etc/init.d/squid

SQUID_OPTS="-YC"

# Kerberos keytab file to use. This is required if you enable kerberos authentication.
SQUID_KEYTAB=""

# Use max_filedescriptors setting in squid.conf to determine the maximum number
# of filedescriptors squid can open.

# Set whether Squid should receive two shutdown signals instead of one. If set to "yes",
# Squid will skip the graceful shutdown step, and will try to immediately close all open
# file descriptors and helpers. This is useful if you experience very long delays when
# shutting down the caching proxy.
SQUID_FAST_SHUTDOWN="no"
123 changes: 123 additions & 0 deletions net-proxy/squid/files/squid.initd-r5
Original file line number Diff line number Diff line change
@@ -0,0 +1,123 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

extra_started_commands="reload rotate"

depend() {
use dns net
}

checkconfig() {
local CONFFILES="/etc/squid/${RC_SVCNAME}.conf /etc/squid/${RC_SVCNAME}.include /etc/squid/${RC_SVCNAME}.include.*"
if [ ! -f /etc/squid/${RC_SVCNAME}.conf ]; then
eerror "You need to create /etc/squid/${RC_SVCNAME}.conf first."
eerror "The main configuration file and all included file names should have the following format:"
eerror "${CONFFILES}"
eerror "An example can be found in /etc/squid/squid.conf.default"
return 1
fi

local PIDFILE=$(cat ${CONFFILES} 2>/dev/null 3>/dev/null | awk '/^[ \t]*pid_filename[ \t]+/ { print $2 }')
[ -z ${PIDFILE} ] && PIDFILE=/run/squid.pid
if [ /run/${RC_SVCNAME}.pid != ${PIDFILE} ]; then
eerror "/etc/squid/${RC_SVCNAME}.conf must set pid_filename to"
eerror " /run/${RC_SVCNAME}.pid"
eerror "CAUTION: http_port, cache_dir and *_log parameters must be different than"
eerror " in any other instance of squid."
eerror "Make sure the main configuration file and all included file names have the following format:"
eerror "${CONFFILES}"
return 1
fi

# Maximum file descriptors squid can open is determined by:
# a basic default of N=1024
# ... altered by ./configure --with-filedescriptors=N
# ... overridden on production by squid.conf max_filedescriptors (if,
# and only if, setrlimit() RLIMIT_NOFILE is able to be built+used).
# Since we do not configure hard coded # of filedescriptors anymore,
# there is no need for ulimit calls in the init script.
# Use max_filedescriptors in squid.conf instead.

local CACHE_SWAP=$(cat ${CONFFILES} 2>/dev/null 3>/dev/null | awk '/^[ \t]*cache_dir[ \t]+/ { if ( $2 == "rock" ) printf "%s/rock ", $3; else if ( $2 == "coss" ) printf "%s/stripe ", $3; else printf "%s/00 ", $3; }')
[ -z "$CACHE_SWAP" ] && CACHE_SWAP="/var/cache/squid/00"

local x
for x in $CACHE_SWAP ; do
if [ ! -e $x ] ; then
ebegin "Initializing cache directory ${x%/*}"
local ORIG_UMASK=$(umask)
umask 027

if ! (mkdir -p ${x%/*} && chown squid ${x%/*}) ; then
eend 1
return 1
fi

local INIT_CACHE_RESPONSE="$(/usr/sbin/squid -z -N -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/} 2>&1)"
if [ $? != 0 ] || echo "$INIT_CACHE_RESPONSE" | grep -q "erminated abnormally" ; then
umask $ORIG_UMASK
eend 1
echo "$INIT_CACHE_RESPONSE"
return 1
fi

umask $ORIG_UMASK
eend 0
break
fi
done

return 0
}

start() {
checkconfig || return 1
checkpath -d -q -m 0750 -o squid:squid /run/${RC_SVCNAME}

# see https://wiki.squid-cache.org/MultipleInstances
ebegin "Starting ${RC_SVCNAME} (service name ${RC_SVCNAME//[^[:alnum:]]/}) with KRB5_KTNAME=\"${SQUID_KEYTAB}\" /usr/sbin/squid ${SQUID_OPTS} -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}"
KRB5_KTNAME="${SQUID_KEYTAB}" /usr/sbin/squid ${SQUID_OPTS} -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}
eend $? && sleep 1
}

stop() {
ebegin "Stopping ${RC_SVCNAME} with /usr/sbin/squid -k shutdown -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}"
if /usr/sbin/squid -k shutdown -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/} ; then
# Now we have to wait until squid has _really_ stopped.
sleep 1
if [ -f /run/${RC_SVCNAME}.pid ] ; then
einfon "Waiting for squid to shutdown ."
cnt=0
while [ -f /run/${RC_SVCNAME}.pid ] ; do
cnt=$(expr $cnt + 1)
if [ $cnt -gt 60 ] ; then
# Waited 120 seconds now. Fail.
echo
eend 1 "Failed."
break
fi
sleep 2
echo -n "."
done
echo
fi
else
eerror "Squid shutdown failed, probably service is already down."
fi
eend 0
}

reload() {
checkconfig || return 1
ebegin "Reloading ${RC_SVCNAME} with /usr/sbin/squid -k reconfigure -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}"
/usr/sbin/squid -k reconfigure -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}
eend $?
}

rotate() {
service_started ${RC_SVCNAME} || return 1
ebegin "Rotating ${RC_SVCNAME} logs with /usr/sbin/squid -k rotate -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}"
/usr/sbin/squid -k rotate -f /etc/squid/${RC_SVCNAME}.conf -n ${RC_SVCNAME//[^[:alnum:]]/}
eend $?
}
Loading

0 comments on commit ee8980c

Please sign in to comment.