Skip to content

Commit

Permalink
dev-lang/clips: new package; add version 6.40
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Nov 26, 2021
1 parent 57ed3f4 commit eeaef85
Show file tree
Hide file tree
Showing 4 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/clips/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST clips-6.40.tar.gz 1082012 BLAKE2B f168a14178ca0d5d39039d9e661e2214f9787099944e11413d7056b0c2a047596e913893a4cb3c4425c311af6bc39ff7710ce649045111e4947f5fcf320527c4 SHA512 92383895c60f1fa02a4c1f426d734ae7140e798dd19c7b1ee668bb4781a20e7d1f2554222ebc2c1f47c03d3262a7a058c3a7840d5dd48c2d2fe761e9a0602399
33 changes: 33 additions & 0 deletions dev-lang/clips/clips-6.40.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="Tool for building Expert Systems (native version)"
HOMEPAGE="http://www.clipsrules.net/"

CLPN="clips_core_source_$(ver_cut 1)$(ver_cut 2)"
SRC_URI="https://sourceforge.net/projects/clipsrules/files/CLIPS/${PV}/${CLPN}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${CLPN}/core"

LICENSE="public-domain"
KEYWORDS="~amd64 ~x86"
SLOT="0"

PATCHES=( "${FILESDIR}/makefile.patch" )

src_prepare() {
tc-export AR CC
default
}

src_compile() {
emake -f makefile
}

src_install() {
dobin clips
dolib.a libclips.a
}
33 changes: 33 additions & 0 deletions dev-lang/clips/files/makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
--- a/makefile
+++ b/makefile
@@ -66,8 +66,10 @@ debug : CFLAGS = -std=c99 -O0 -g
debug : LDLIBS = -lm
debug : clips

-release : CC = gcc
-release : CFLAGS = -std=c99 -O3 -fno-strict-aliasing
+release : AR ?=
+release : CC ?=
+release : CFLAGS ?=
+release : LDFLAGS ?=
release : LDLIBS = -lm
release : clips

@@ -88,14 +90,14 @@ release_cpp : LDLIBS = -lstdc++
release_cpp : clips

.c.o :
- $(CC) -c -D$(CLIPS_OS) $(CFLAGS) $(WARNINGS) $<
+ $(CC) -c -D$(CLIPS_OS) $(CFLAGS) $(LDFLAGS) $<

clips : main.o libclips.a
- $(CC) -o clips main.o -L. -lclips $(LDLIBS)
+ $(CC) -o clips main.o -L. -lclips $(CFLAGS) $(LDFLAGS) $(LDLIBS)

libclips.a : $(OBJS)
rm -f $@
- ar cq $@ $(OBJS)
+ $(AR) cq $@ $(OBJS)

clean :
-rm -f main.o $(OBJS)
18 changes: 18 additions & 0 deletions dev-lang/clips/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">

<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Maciej Barć</name>
</maintainer>
<longdescription lang="en">
This package is a pure C implementation of CLIPS.
CLIPS is a forward-chaining rule-based programming language written in C
that also provides procedural and object-oriented programming facilities.
</longdescription>
<upstream>
<bugs-to>https://sourceforge.net/p/clipsrules/bugs/milestone/CLIPS/</bugs-to>
<remote-id type="sourceforge">clipsrules</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit eeaef85

Please sign in to comment.