Skip to content

Commit

Permalink
gnustep-base/gnustep-base: add libressl support
Browse files Browse the repository at this point in the history
Upstream recommends gnutls over openssl/libressl, the ebuild reflects that

Package-Manager: portage-2.2.24
  • Loading branch information
voyageur committed Nov 10, 2015
1 parent 10634ab commit eec22f5
Showing 1 changed file with 88 additions and 0 deletions.
88 changes: 88 additions & 0 deletions gnustep-base/gnustep-base/gnustep-base-1.24.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils gnustep-base

DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"

LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE="+gnutls +icu +libffi libressl +ssl zeroconf"

RDEPEND="${GNUSTEP_CORE_DEPEND}
>=gnustep-base/gnustep-make-2.6.0
ssl? (
gnutls? ( net-libs/gnutls )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
)
>=dev-libs/openssl-0.9.7:=
icu? ( >=dev-libs/icu-4.0:= )
!libffi? ( dev-libs/ffcall
gnustep-base/gnustep-make[-native-exceptions] )
libffi? ( virtual/libffi )
>=dev-libs/libxml2-2.6
>=dev-libs/libxslt-1.1
>=dev-libs/gmp-4.1:=
>=sys-libs/zlib-1.2
zeroconf? ( net-dns/avahi )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
egnustep_env

local myconf
if use libffi ; then
myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
else
myconf="--disable-libffi --enable-ffcall"
fi

if use ssl ; then
if use gnutls ; then
myconf="$myconf --enable-tls --disable-openssl"
else
myconf="$myconf --disable-tls --enable-openssl"
fi
else
myconf="$myconf --disable-tls --disable-openssl"
fi
myconf="$myconf $(use_enable icu)"
myconf="$myconf $(use_enable zeroconf)"
myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"

econf $myconf
}

src_install() {
# We need to set LD_LIBRARY_PATH because the doc generation program
# uses the gnustep-base libraries. Since egnustep_env "cleans the
# environment" including our LD_LIBRARY_PATH, we're left no choice
# but doing it like this.

egnustep_env
egnustep_install

if use doc ; then
export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
egnustep_doc
fi
egnustep_install_config
}

0 comments on commit eec22f5

Please sign in to comment.