Skip to content

Commit

Permalink
media-libs/aalib: refresh up to EAPI=7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Nov 10, 2019
1 parent c8a3e9d commit eed715a
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 2 deletions.
73 changes: 73 additions & 0 deletions media-libs/aalib/aalib-1.4_rc5-r9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools multilib-minimal toolchain-funcs

MY_P="${P/_/}"
S="${WORKDIR}/${PN}-1.4.0"

DESCRIPTION="A ASCII-Graphics Library"
HOMEPAGE="http://aa-project.sourceforge.net/aalib/"
SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="X slang gpm static-libs"

RDEPEND="
X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
gpm? ( >=sys-libs/gpm-1.20.7-r2[${MULTILIB_USEDEP}] )
slang? ( >=sys-libs/slang-2.2.4-r1[${MULTILIB_USEDEP}] )
>=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
virtual/pkgconfig
X? ( x11-base/xorg-proto )
"

DOCS="ANNOUNCE AUTHORS ChangeLog NEWS README*"

PATCHES=(
"${FILESDIR}"/${PN}-1.4_rc4-gentoo.patch
"${FILESDIR}"/${PN}-1.4_rc4-m4.patch
"${FILESDIR}"/${PN}-1.4_rc5-fix-protos.patch #224267
"${FILESDIR}"/${PN}-1.4_rc5-fix-aarender.patch #214142
"${FILESDIR}"/${PN}-1.4_rc5-tinfo.patch #468566
"${FILESDIR}"/${PN}-1.4_rc5-key-down-OOB.patch
"${FILESDIR}"/${PN}-1.4_rc5-more-protos.patch
)

src_prepare() {
default

sed -i -e 's:#include <malloc.h>:#include <stdlib.h>:g' "${S}"/src/*.c

# Fix bug #165617.
use gpm || sed -i \
's/gpm_mousedriver_test=yes/gpm_mousedriver_test=no/' "${S}/configure.in"

#467988 automake-1.13
mv configure.{in,ac} || die
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die

eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE=${S} econf \
$(use_with slang slang-driver) \
$(use_with X x11-driver) \
$(use_enable static-libs static) \
PKG_CONFIG=$(tc-getPKG_CONFIG)
}

multilib_src_install() {
emake DESTDIR="${D}" install

if ! use static-libs; then
find "${D}" -name '*.la' -type f -delete || die
fi
}
4 changes: 2 additions & 2 deletions media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch
Original file line number Diff line number Diff line change
Expand Up @@ -19,8 +19,8 @@ image, not cause part of it to miss.
Gentoo-bug: http://bugs.gentoo.org/id=214142
Reported-by: Reimar Döffinger
Fixed-by: Reimar Döffinger
--- src/aarender.c.orig 2008-03-18 23:55:32.000000000 +0100
+++ src/aarender.c 2008-03-18 23:55:50.000000000 +0100
--- a/src/aarender.c.orig 2008-03-18 23:55:32.000000000 +0100
+++ b/src/aarender.c 2008-03-18 23:55:50.000000000 +0100
@@ -94,8 +94,8 @@
gamma = randomval / 2;
mval = (c->parameters[c->filltable[255]].p[4]);
Expand Down

0 comments on commit eed715a

Please sign in to comment.